sling-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andreas Schaefer <schaef...@me.com.INVALID>
Subject Re: Sling Content Package to Feature Model Issue
Date Sat, 04 May 2019 19:40:03 GMT
Created a ticket here:

https://issues.apache.org/jira/browse/SLING-8396

I actually have a content package that did not have any not-provided bundles in the dependencies
and with that the core was added.

- Andy

> On May 4, 2019, at 8:26 AM, Dominik Süß <dominik.suess@gmail.com> wrote:
> 
> Hi Andreas,
> 
> if looks like you found a bug in there due to the embedded jars:
> [INFO] Processing bundle core-1.0.0-SNAPSHOT.jar...
> [INFO] Reading 'core-1.0.0-SNAPSHOT.jar' bundle GAV from
> META-INF/maven/com.madplanet.sling.cp2sf/core/pom.properties...
> [INFO] Reading 'core-1.0.0-SNAPSHOT.jar' bundle GAV from
> META-INF/maven/commons-lang/commons-lang/pom.properties...
> 
> In fact the referred
> commons-lang:commons-lang:2.6 bundle in that IS the core bundle as it takes
> the last pom.properties  if found and uses those to install the artifact.
> Simo already fixed a case where missing pom.properties caused trouble, in
> this case, I'm not sure how that is supposed to work exactly.
> 
> Please open a corresponding bug - Simo will most certainly address this by
> Monday as he is far deeper in the maven specifics.
> 
> Cheers
> Dominik
> 
> Andreas Schaefer <schaefera@me.com.invalid> schrieb am Fr. 3. Mai 2019 um
> 17:38:
> 
>> Hi
>> 
>> I have a content package with an embedded Bundle in it (ui.apps -> core).
>> When running the latest Content Package to Feature Model Converter the
>> bundle is extracted from the package as well as removed from the filter.xml
>> file but it is not added to the feature model json file.
>> 
>> Here is a demo project for it:
>> https://github.com/schaefa/sling-content-2-feature-issue
>> 
>> This is the FM json file:
>> 
>> https://github.com/schaefa/sling-content-2-feature-issue/blob/master/fm.out/ui.apps.json
>> 
>> When I add the System Console I do not see the bundle. In order to make it
>> install I had to add it to the ui.apps.json file:
>> 
>>  "bundles":[
>>    {
>>      "id":"commons-lang:commons-lang:2.6",
>>      "start-order":"20"
>>    },
>>    {
>>      "id":"com.madplanet.sling.cp2sf:core:jar:1.0.0-SNAPSHOT",
>>      "start-order":"20"
>>    },
>> 
>> Is this done on purpose?
>> 
>> Cheers - Andy Schaefer


Mime
View raw message