sling-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From GitBox <...@apache.org>
Subject [GitHub] JEBailey commented on a change in pull request #1: Sling 3270
Date Thu, 10 Jan 2019 15:55:13 GMT
JEBailey commented on a change in pull request #1: Sling 3270
URL: https://github.com/apache/sling-org-apache-sling-commons-html/pull/1#discussion_r246815074
 
 

 ##########
 File path: pom.xml
 ##########
 @@ -37,25 +37,36 @@
 
     <properties>
         <sling.java.version>8</sling.java.version>
-        <org.ops4j.pax.exam.version>4.11.0</org.ops4j.pax.exam.version>
+        <org.ops4j.pax.exam.version>4.12.0</org.ops4j.pax.exam.version>
+        <project.build.sourceEncoding>UTF-8</project.build.sourceEncoding>
+        <project.resources.sourceEncoding>UTF-8</project.resources.sourceEncoding>
     </properties>
 
     <scm>
         <connection>scm:git:https://gitbox.apache.org/repos/asf/sling-org-apache-sling-commons-html.git</connection>
         <developerConnection>scm:git:https://gitbox.apache.org/repos/asf/sling-org-apache-sling-commons-html.git</developerConnection>
         <url>https://gitbox.apache.org/repos/asf?p=sling-org-apache-sling-commons-html.git</url>
-      <tag>HEAD</tag>
-  </scm>
+        <tag>HEAD</tag>
+    </scm>
 
     <build>
         <plugins>
             <plugin>
-                <groupId>biz.aQute.bnd</groupId>
-                <artifactId>bnd-maven-plugin</artifactId>
 
 Review comment:
   @kwin  I misunderstood, from my experience between the two it feels like the bnd-maven-plugin
is the step back. However to answer your question. Of the multiple concerns that I encountered,
the specific problem is that the baselining is ignoring the package-info.java 
   
   when I use bnd-maven-plugin I get the following
   ```
   [INFO] --- bnd-baseline-maven-plugin:3.5.0:baseline (default) @ org.apache.sling.commons.html
---
   [INFO] Automatically determining the baseline version for org.apache.sling:org.apache.sling.commons.html:jar:1.0.3-SNAPSHOT
using repositories [apache.snapshots.https (https://repository.apache.org/content/repositories/snapshots,
default, releases+snapshots), central (https://artifact.unx.sas.com:443/artifactory/es-maven-libs-release,
default, releases), snapshots (https://artifact.unx.sas.com:443/artifactory/es-maven-libs-snapshot,
default, releases+snapshots), apache.snapshots (https://repository.apache.org/snapshots, default,
snapshots)]
   [INFO] The baseline version was found to be 1.0.2
   [ERROR] The bundle version change (1.0.2 to 1.0.3) is too low, the new version must be
at least 1.1.0
   ```
   It's obtaining the versioning information from the bundle instead of the package-info.

----------------------------------------------------------------
This is an automated message from the Apache Git Service.
To respond to the message, please log on GitHub and use the
URL above to go to the specific comment.
 
For queries about this service, please contact Infrastructure at:
users@infra.apache.org


With regards,
Apache Git Services

Mime
View raw message