sling-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ASF GitHub Bot (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (SLING-8136) Analyser fails when javax.*, org.xml.sax.*, org.w3c.dom* or org.ietf.jgss imports are found
Date Wed, 28 Nov 2018 12:29:00 GMT

    [ https://issues.apache.org/jira/browse/SLING-8136?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16701815#comment-16701815
] 

ASF GitHub Bot commented on SLING-8136:
---------------------------------------

rombert commented on issue #11: SLING-8136 - Analyser fails when javax.*, org.xml.sax.*, org.w3c.dom*
or org.ietf.jgss imports are found
URL: https://github.com/apache/sling-org-apache-sling-feature-analyser/pull/11#issuecomment-442429819
 
 
   @karlpauls provided a proper fix in https://github.com/apache/sling-org-apache-sling-feature-analyser/commit/591bfb9,
closing

----------------------------------------------------------------
This is an automated message from the Apache Git Service.
To respond to the message, please log on GitHub and use the
URL above to go to the specific comment.
 
For queries about this service, please contact Infrastructure at:
users@infra.apache.org


> Analyser fails when javax.*, org.xml.sax.*, org.w3c.dom* or org.ietf.jgss imports are
found
> -------------------------------------------------------------------------------------------
>
>                 Key: SLING-8136
>                 URL: https://issues.apache.org/jira/browse/SLING-8136
>             Project: Sling
>          Issue Type: Bug
>          Components: Feature Model
>            Reporter: Robert Munteanu
>            Assignee: Karl Pauls
>            Priority: Major
>             Fix For: Feature Model Analyser 0.8.2
>
>
> I've tried running the {{slingfeature-maven-plugin}} to analyse imports and exports using
the {{bundle-packages}} analyser.
> This seems to work just fine, just that some packages - found in the issue title - are
not seen as being provided by the framework. Some errors that pop up are:
> {noformat}
> [ERROR] Bundle oak-auth-ldap:1.9.11 is importing package(s) org.ietf.jgss in start level
0 but no bundle is exporting these for that start level.
> [ERROR] Bundle oak-lucene:1.9.11 is importing package(s) [org.xml.sax.helpers, org.xml.sax]
in start level 0 but no bundle is exporting these for that start level.
> {noformat}
> These packages are provided using an {{org.osgi.framework.system.packages}} framework
property, so I guess there is some glue missing to make this work.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message