sling-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Robert Munteanu (JIRA)" <j...@apache.org>
Subject [jira] [Resolved] (SLING-7414) WebConsole security provider 1.1.0 or newer do not work with the Sling Starter
Date Mon, 15 Oct 2018 14:43:00 GMT

     [ https://issues.apache.org/jira/browse/SLING-7414?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Robert Munteanu resolved SLING-7414.
------------------------------------
    Resolution: Fixed

Fixed in [sling-org-apache-sling-auth-form commit 156d2c2|https://github.com/apache/sling-org-apache-sling-auth-form/commit/156d2c2]


> WebConsole security provider 1.1.0 or newer do not work with the Sling Starter
> ------------------------------------------------------------------------------
>
>                 Key: SLING-7414
>                 URL: https://issues.apache.org/jira/browse/SLING-7414
>             Project: Sling
>          Issue Type: Bug
>          Components: Extensions
>    Affects Versions: Form Based Authentication 1.0.10
>            Reporter: Robert Munteanu
>            Assignee: Robert Munteanu
>            Priority: Critical
>             Fix For: Form Based Authentication 1.0.12
>
>
> When upgrading the webconsole security provider in the Sling starter to 1.2.0, the following
problems occur:
> * the SmokeIT fails since accessing {{/system/console/bundles.json}} redirects to an
HTML login form
> * accessing the OSGi console at {{/system/console}} presents a login form at http://localhost:8080/system/sling/form/login?resource=%2Fsystem%2Fconsole,
but then redirects to http://localhost:8080/system/console/j_security_check . Re-accessing
{{/system/console}} brings up the login form again.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message