sling-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Hasini Witharana <hasinidila...@gmail.com>
Subject Re: [Dev] OSGI Bundle Error when using " Nimbus OAuth 2.0 SDK with OpenID Connect extensions" as a dependency
Date Sat, 02 Jun 2018 19:25:14 GMT
Hi Robert,

This helped a lot. I deployed the bundle (oauth2-oidc-sdk) successfully.

Thank You.

On Fri, Jun 1, 2018 at 2:49 AM, Robert Munteanu <rombert@apache.org> wrote:

> On Fri, 2018-06-01 at 01:03 +0530, Hasini Witharana wrote:
> > Unresolved requirements: [[oauth2-oidc-sdk [166](R 166.0)]
> > osgi.wiring.package;
> > (&(osgi.wiring.package=com.nimbusds.jose)(version>=5.10.0)(!(version>
> > =6.0.0)))]
> >     at
>
> This means that the bundle you just added to Sling ( oauth2-oidc-sdk )
> requires a package "com.nimbusds.jose" with version between 5.10.0 and
> 6.0.0 . That package seems to be provided by [1], which has support for
> OSGi [2]. So you would need to deploy that bundle as well ... I guess
> you need to iterate until you've found a definitive list of
> dependencies you need to deploy.
>
> Hope this helps,
>
> Robert
>
>
> [1]: https://bitbucket.org/connect2id/nimbus-jose-jwt
> [2]: https://bitbucket.org/connect2id/nimbus-jose-jwt/src/
> e6632b6858b34ecbe9258c2f5a1e7c7c60ffb973/pom.xml?at=master&
> fileviewer=file-view-default#pom.xml-225:227
>



-- 
*Hasini Witharana*
Undergraduate | Department of Computer Science and Engineering
University of Moratuwa
Linkedin <https://www.linkedin.com/in/hasini-witharana-185785109/>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message