sling-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "David Bosschaert (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (SLING-7496) Factory config deleted with ConfigAdmin immediately after creation
Date Sat, 17 Feb 2018 12:25:00 GMT

    [ https://issues.apache.org/jira/browse/SLING-7496?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16368205#comment-16368205
] 

David Bosschaert commented on SLING-7496:
-----------------------------------------

I'll have a look at that test failure early next week. 

> Factory config deleted with ConfigAdmin immediately after creation
> ------------------------------------------------------------------
>
>                 Key: SLING-7496
>                 URL: https://issues.apache.org/jira/browse/SLING-7496
>             Project: Sling
>          Issue Type: Bug
>          Components: Installer
>    Affects Versions: Installer Configuration Factory 1.1.2
>            Reporter: David Bosschaert
>            Assignee: Carsten Ziegeler
>            Priority: Major
>             Fix For: Installer Configuration Factory 1.2.0
>
>
> In some cases when a factory configuration is created using the OSGi ConfigAdmin API,
the configuration gets a call to {{delete()}} immediately when {{update()}} on the configuration
is called.
>  
> The issue comes down to the fact that the factory prefix is prepended twice to the configuration
at some point in the installer, which is then assigned to the resource {{entityId}}. This
mismatch causes the initial configuration to receive a delete callback as the system thinks
it's no longer there.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message