sling-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Oliver Lietz (JIRA)" <j...@apache.org>
Subject [jira] [Closed] (SLING-7184) SlingOptions.slingScriptingSightly fails to
Date Fri, 02 Feb 2018 13:46:00 GMT

     [ https://issues.apache.org/jira/browse/SLING-7184?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Oliver Lietz closed SLING-7184.
-------------------------------

> SlingOptions.slingScriptingSightly fails to 
> --------------------------------------------
>
>                 Key: SLING-7184
>                 URL: https://issues.apache.org/jira/browse/SLING-7184
>             Project: Sling
>          Issue Type: Bug
>          Components: Testing
>    Affects Versions: Testing PaxExam 0.0.4
>            Reporter: Nicolas Peltier
>            Assignee: Oliver Lietz
>            Priority: Major
>             Fix For: Testing PaxExam 1.0.0
>
>
> trying to use SlingOptions.slingScriptingSightly  in pipes IT i get the following error:
> {Code}
> org.osgi.framework.BundleException: Unable to resolve org.apache.sling.scripting.sightly.js.provider
[208](R 208.0): missing requirement [org.apache.sling.scripting.sightly.js.provider [208](R
208.0)] io.sightly; (&(version>=1.0)(!(version>=2.0))) [caused by: Unable to resolve
org.apache.sling.scripting.sightly [205](R 205.0): missing requirement [org.apache.sling.scripting.sightly
[205](R 205.0)] osgi.wiring.package; (&(osgi.wiring.package=org.apache.sling.xss)(version>=1.0.0)(!(version>=2.0.0)))
[caused by: Unable to resolve org.apache.sling.xss [201](R 201.0): missing requirement [org.apache.sling.xss
[201](R 201.0)] osgi.wiring.package; (osgi.wiring.package=javax.mail.internet)]] Unresolved
requirements: [[org.apache.sling.scripting.sightly.js.provider [208](R 208.0)] io.sightly;
(&(version>=1.0)(!(version>=2.0)))]
> {Code}
> "fixing" this with 
> {Code}
>         SlingOptions.versionResolver.setVersion("org.apache.sling", "org.apache.sling.xss",
"1.0.18");
> ...
>             mavenBundle().groupId("javax.mail").artifactId("mail").version("1.5.0-b01"),
> {Code}



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message