sling-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Robert Munteanu (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (SLING-5649) Non-Eclipse Modules should not depend on Eclipse Depedencies
Date Mon, 26 Feb 2018 21:07:02 GMT

     [ https://issues.apache.org/jira/browse/SLING-5649?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Robert Munteanu updated SLING-5649:
-----------------------------------
    Fix Version/s:     (was: Sling Eclipse IDE 1.2.2)
                   Sling Eclipse IDE 1.2.4

> Non-Eclipse Modules should not depend on Eclipse Depedencies
> ------------------------------------------------------------
>
>                 Key: SLING-5649
>                 URL: https://issues.apache.org/jira/browse/SLING-5649
>             Project: Sling
>          Issue Type: Improvement
>          Components: IDE
>    Affects Versions: Sling Eclipse IDE 1.0.10
>            Reporter: Andreas Schaefer
>            Priority: Major
>             Fix For: Sling Eclipse IDE 1.2.4
>
>
> Currently modules like api, artifacts, imll-resource, impl-vlt have their depends obtained
using Tycho which depends on the supported Eclipse version.
> Other IDEs like IntelliJ IDEA cannot handle that and so development is difficult and
time consuming.
> Also other IDEs that do not use OSGi might have an issue when Eclipse version changes.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message