sling-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "frederic rougeot (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (SLING-7443) Actual build for standalone jar is not working with latest JDK
Date Thu, 25 Jan 2018 10:04:00 GMT

    [ https://issues.apache.org/jira/browse/SLING-7443?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16339017#comment-16339017
] 

frederic rougeot commented on SLING-7443:
-----------------------------------------

I used the 9 release.

I tried with with JDK 1.8.0.161 also it also fails.

but building the 10-SNAPSHOT from source code works well (I tried).

 

It seems that the problem is that the 9 release has been built with a non supported anymore
JDK

 

 

> Actual build for standalone jar is not working with latest JDK
> --------------------------------------------------------------
>
>                 Key: SLING-7443
>                 URL: https://issues.apache.org/jira/browse/SLING-7443
>             Project: Sling
>          Issue Type: Bug
>          Components: Launchpad
>         Environment: Windows 10, JDK 9 or latest 1.8
>            Reporter: frederic rougeot
>            Priority: Major
>              Labels: starter
>
> I tried to use your standalone jar with latest JDK, I mean JDK 9, or JDK 1.8.0_162b12,
but it does not work ... The following log is encountered with JDK 1.8.162 when launching
java -jar org.apache.sling.launchpad-9.jar:
> 24.01.2018 15:45:34.872 *ERROR* [FelixStartLevel] ERROR: Bundle '18' Error starting slinginstall:C:\projets\Veolia\tools\sling\startup\1\slf4j-api-1.7.21.jar
(org.osgi.framework.BundleException: Unable to resolve slf4j.api [18](R 18.0): missing requirement
[slf4j.api [18](R 18.0)] ...
>  
> So I will try now with JDK 1.8.0.161 (a colleague tells me it was quite OK with JDK 1.8.0.77à



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message