sling-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Stefan Seifert (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (SLING-7369) Remove deprecated bndlib dependency
Date Tue, 09 Jan 2018 10:58:00 GMT

    [ https://issues.apache.org/jira/browse/SLING-7369?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16318250#comment-16318250
] 

Stefan Seifert commented on SLING-7369:
---------------------------------------

it's no problem to add such a dependency to the project pom itself, no need to have it in
the parent pom.

> Remove deprecated bndlib dependency
> -----------------------------------
>
>                 Key: SLING-7369
>                 URL: https://issues.apache.org/jira/browse/SLING-7369
>             Project: Sling
>          Issue Type: Bug
>          Components: General
>    Affects Versions: Parent 32
>            Reporter: Konrad Windszus
>            Assignee: Konrad Windszus
>             Fix For: Parent 33
>
>
> The annotations being provided from dependency {{biz.aQute.bnd:biz.aQute.bndlib}} are
deprecated since bnd 3.2.0 (https://github.com/bndtools/bnd/wiki/Changes-in-3.2.0#backwards-compatibility)
and should therefore no longer be used. The according dependency from parent should be removed.
> The according discussion can be found at https://issues.apache.org/jira/browse/SLING-7347?focusedCommentId=16314706&page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#comment-16314706.



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message