sling-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Karl Pauls (JIRA)" <j...@apache.org>
Subject [jira] [Comment Edited] (SLING-7046) Run the Sling ITs with Java 9
Date Thu, 09 Nov 2017 23:05:00 GMT

    [ https://issues.apache.org/jira/browse/SLING-7046?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16246735#comment-16246735
] 

Karl Pauls edited comment on SLING-7046 at 11/9/17 11:04 PM:
-------------------------------------------------------------

Above PR makes it so that we add java.se.ee to the testing when on java9 as it is required
atm. I guess we have to eventually decide whether that is good enough for now (in which case
we can merge the PR - I created SLING-7235 so that we don't forget to get back to it) or whether
we want to remove that dependency completely (in which case we don't need this PR). 

At any rate, together with my PR: https://github.com/apache/sling-org-apache-sling-launchpad-base/pull/1
for SLING-7186 it makes the IT pass on java9.


was (Author: karlpauls):
Above PR makes it so that we add java.se.ee to the testing when on java9. Together with my
PR: https://github.com/apache/sling-org-apache-sling-launchpad-base/pull/1 for SLING-7186
it makes the testing work. I guess we have to eventually decide whether that is good enough
for now (in which case we can merge the PR - I created SLING-7235 so that we don't forget
to get back to it) or whether we want to remove that dependency completely (in which case
we don't need this PR). 

> Run the Sling ITs with Java 9
> -----------------------------
>
>                 Key: SLING-7046
>                 URL: https://issues.apache.org/jira/browse/SLING-7046
>             Project: Sling
>          Issue Type: Bug
>          Components: Launchpad
>            Reporter: Robert Munteanu
>             Fix For: Launchpad Testing 9
>
>
> Java 9 RC1 is out, with a [release date of 21st of September|http://mail.openjdk.java.net/pipermail/jdk9-dev/2017-May/005864.html].
> With all the basics put into place, we should enable ITs running with Java 9, to ensure
we have at least some support on launch day.



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message