sling-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Felix Meschberger <fmesc...@gmail.com>
Subject Re: Need for servlet-api 2.4 and jsp 2.0
Date Thu, 03 Jan 2008 07:14:09 GMT
Hi,

Am Mittwoch, den 02.01.2008, 12:13 +0200 schrieb Jukka Zitting:
> What parts of Sling require servlet-api 2.4 and jsp 2.0 over
> servlet-api 2.3 and jsp 1.2? How strict are these requirements?
> Basically, how hard it would be to make run Sling on a 2.3 servlet
> container?

As Carsten pointed out the version of JSP support is more or less
irrelevant to the discussion of requiring Servlet API 2.3 vs. 2.4. In
fact the current JSP support being based on Jasper 6 even is JSP 2.1
which by definition would even require Servlet API 2.5.

Back to the Servlet API 2.3 vs. 2.4 question: It is not just the
setCharacterEncoding method, it is also some getter methods on the
HttpServletResponse added in 2.4 we are using.

Regards
Felix


Mime
View raw message