sling-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Juan José Vázquez Delgado" <juanjo.vazq...@gmail.com>
Subject Re: Component -> Slinglet?
Date Wed, 19 Sep 2007 07:40:16 GMT
Hi,

In fact, "Component" sounds too much common. I agree with the name Slinglet
(in a portlet style...)

BR,

Juanjo.

On 9/19/07, Bertrand Delacretaz <bdelacretaz@apache.org> wrote:
>
> Hi Slingers,
>
> The "Component" name, used by Sling to designate objects that render
> parts of content, is a bit confusing, especially w.r.t. OSGi
> Components which are software modules.
>
> We talked about this at work with Felix, Carsten and others, and we
> agree that a more specific name would help in understanding,
> describing and documenting Sling.
>
> How about Slinglets?
>
>   "Slinglets are used by Sling to render pieces of content"
>
> -Bertrand
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message