sling-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From r...@apache.org
Subject svn commit: r1765833 - in /sling/site/trunk/content: downloads.list news.mdtext obr/sling.xml
Date Thu, 20 Oct 2016 15:25:33 GMT
Author: radu
Date: Thu Oct 20 15:25:32 2016
New Revision: 1765833

URL: http://svn.apache.org/viewvc?rev=1765833&view=rev
Log:
Added Apache Sling Scripting HTL JS Use Provider 1.0.16 

Modified:
    sling/site/trunk/content/downloads.list
    sling/site/trunk/content/news.mdtext
    sling/site/trunk/content/obr/sling.xml

Modified: sling/site/trunk/content/downloads.list
URL: http://svn.apache.org/viewvc/sling/site/trunk/content/downloads.list?rev=1765833&r1=1765832&r2=1765833&view=diff
==============================================================================
--- sling/site/trunk/content/downloads.list (original)
+++ sling/site/trunk/content/downloads.list Thu Oct 20 15:25:32 2016
@@ -159,7 +159,7 @@ Scripting Groovy|org.apache.sling.script
 Scripting HTL Compiler|org.apache.sling.scripting.sightly.compiler|1.0.2
 Scripting HTL Java Compiler|org.apache.sling.scripting.sightly.compiler.java|1.0.4
 Scripting HTL Engine|org.apache.sling.scripting.sightly|1.0.24
-Scripting HTL JavaScript Use Provider|org.apache.sling.scripting.sightly.js.provider|1.0.14
+Scripting HTL JavaScript Use Provider|org.apache.sling.scripting.sightly.js.provider|1.0.16
 Scripting HTL Sling Models Use Provider|org.apache.sling.scripting.sightly.models.provider|1.0.4
 Scripting HTL REPL|org.apache.sling.scripting.sightly.repl|1.0.4
 Scripting Thymeleaf|org.apache.sling.scripting.thymeleaf|1.0.0

Modified: sling/site/trunk/content/news.mdtext
URL: http://svn.apache.org/viewvc/sling/site/trunk/content/news.mdtext?rev=1765833&r1=1765832&r2=1765833&view=diff
==============================================================================
--- sling/site/trunk/content/news.mdtext (original)
+++ sling/site/trunk/content/news.mdtext Thu Oct 20 15:25:32 2016
@@ -1,5 +1,5 @@
 Title: News
-* New Releases: Apache Sling Scripting JSP 2.2.0, Apache Sling Engine 2.6.6, and Apache Sling
Scripting Java 2.1.0 (October 20th, 2016)
+* New Releases: Apache Sling Scripting JSP 2.2.0, Apache Sling Engine 2.6.6, Apache Sling
Scripting Java 2.1.0, Apache Sling Scripting HTL JS Use Provider 1.0.16 (October 20th, 2016)
 * New Releases: Apache Sling Scripting Core 2.0.40, Apache Sling Scripting HTL Java Compiler
1.0.4, Apache Sling Scripting HTL Engine 1.0.24 (October 17th, 2016)
 * New Release: Apache Sling Launchpad Base 2.6.12 (October 16th, 2016)
 * New Releases: Apache Sling Event 3.4.0, Apache Sling Distributed Eventing 1.1.0, and Apache
Sling Rewriter 1.2.0 (October 15th, 2016)

Modified: sling/site/trunk/content/obr/sling.xml
URL: http://svn.apache.org/viewvc/sling/site/trunk/content/obr/sling.xml?rev=1765833&r1=1765832&r2=1765833&view=diff
==============================================================================
--- sling/site/trunk/content/obr/sling.xml (original)
+++ sling/site/trunk/content/obr/sling.xml Thu Oct 20 15:25:32 2016
@@ -1,4 +1,4 @@
-<repository name='Apache Sling Release Repository' lastmodified='20161017063130.476'>
+<repository name='Apache Sling Release Repository' lastmodified='20161020052500.787'>
   <resource id='org.apache.sling.extensions.classloader-leak-detector/1.0.0' symbolicname='org.apache.sling.extensions.classloader-leak-detector'
presentationname='Adobe Sling ClassLoader Leak Detector' uri='http://repo1.maven.org/maven2/org/apache/sling/org.apache.sling.extensions.classloader-leak-detector/1.0.0/org.apache.sling.extensions.classloader-leak-detector-1.0.0.jar'
version='1.0.0'>
     <description>Provides a web console configuration printer to provide details around
classloader leaks</description>
     <size>18203</size>
@@ -11073,6 +11073,36 @@
     <require name='package' filter='(&amp;(package=org.slf4j)(version&gt;=1.7.0)(!(version&gt;=2.0.0)))'
extend='false' multiple='false' optional='false'>Import package org.slf4j;version="[1.7,2)"</require>
     <require name='ee' filter='(|(ee=JavaSE-1.7))' extend='false' multiple='false' optional='false'>Execution
Environment (|(ee=JavaSE-1.7))</require>
   </resource>
+  <resource id='org.apache.sling.scripting.sightly.js.provider/1.0.16' symbolicname='org.apache.sling.scripting.sightly.js.provider'
presentationname='Apache Sling Scripting HTL JavaScript Use Provider' uri='http://repo1.maven.org/maven2/org/apache/sling/org.apache.sling.scripting.sightly.js.provider-1.0.16.jar'
version='1.0.16'>
+    <description>The Apache Sling HTL JavaScript Use Provider adds support for accessing
JS scripts from HTL&apos;s Use-API.</description>
+    <size>81748</size>
+    <documentation>http://sling.apache.org</documentation>
+    <license>https://www.apache.org/licenses/LICENSE-2.0.txt</license>
+    <category id='sling'/>
+    <capability name='bundle'>
+      <p n='symbolicname' v='org.apache.sling.scripting.sightly.js.provider'/>
+      <p n='presentationname' v='Apache Sling Scripting HTL JavaScript Use Provider'/>
+      <p n='version' t='version' v='1.0.16'/>
+      <p n='manifestversion' v='2'/>
+    </capability>
+    <require name='package' filter='(&amp;(package=javax.script))' extend='false'
multiple='false' optional='false'>Import package javax.script</require>
+    <require name='package' filter='(&amp;(package=javax.servlet.http)(version&gt;=3.1.0)(!(version&gt;=4.0.0)))'
extend='false' multiple='false' optional='false'>Import package javax.servlet.http;version="[3.1,4)"</require>
+    <require name='package' filter='(&amp;(package=org.apache.commons.io)(version&gt;=1.4.0)(!(version&gt;=2.0.0)))'
extend='false' multiple='false' optional='false'>Import package org.apache.commons.io;version="[1.4,2)"</require>
+    <require name='package' filter='(&amp;(package=org.apache.commons.lang)(version&gt;=2.5.0)(!(version&gt;=3.0.0)))'
extend='false' multiple='false' optional='false'>Import package org.apache.commons.lang;version="[2.5,3)"</require>
+    <require name='package' filter='(&amp;(package=org.apache.sling.api)(version&gt;=2.2.0)(!(version&gt;=3.0.0)))'
extend='false' multiple='false' optional='false'>Import package org.apache.sling.api;version="[2.2,3)"</require>
+    <require name='package' filter='(&amp;(package=org.apache.sling.api.resource)(version&gt;=2.4.0)(!(version&gt;=3.0.0)))'
extend='false' multiple='false' optional='false'>Import package org.apache.sling.api.resource;version="[2.4,3)"</require>
+    <require name='package' filter='(&amp;(package=org.apache.sling.api.scripting)(version&gt;=2.1.0)(!(version&gt;=3.0.0)))'
extend='false' multiple='false' optional='false'>Import package org.apache.sling.api.scripting;version="[2.1,3)"</require>
+    <require name='package' filter='(&amp;(package=org.apache.sling.commons.osgi))'
extend='false' multiple='false' optional='false'>Import package org.apache.sling.commons.osgi</require>
+    <require name='package' filter='(&amp;(package=org.apache.sling.scripting.api)(version&gt;=2.3.0)(!(version&gt;=3.0.0)))'
extend='false' multiple='false' optional='false'>Import package org.apache.sling.scripting.api;version="[2.3,3)"</require>
+    <require name='package' filter='(&amp;(package=org.apache.sling.scripting.core)(version&gt;=2.1.0)(!(version&gt;=3.0.0)))'
extend='false' multiple='false' optional='false'>Import package org.apache.sling.scripting.core;version="[2.1,3)"</require>
+    <require name='package' filter='(&amp;(package=org.apache.sling.scripting.sightly)(version&gt;=1.0.0)(!(version&gt;=2.0.0)))'
extend='false' multiple='false' optional='false'>Import package org.apache.sling.scripting.sightly;version="[1.0,2)"</require>
+    <require name='package' filter='(&amp;(package=org.apache.sling.scripting.sightly.render)(version&gt;=2.0.0)(!(version&gt;=3.0.0)))'
extend='false' multiple='false' optional='false'>Import package org.apache.sling.scripting.sightly.render;version="[2.0,3)"</require>
+    <require name='package' filter='(&amp;(package=org.apache.sling.scripting.sightly.use)(version&gt;=1.0.0)(!(version&gt;=2.0.0)))'
extend='false' multiple='false' optional='false'>Import package org.apache.sling.scripting.sightly.use;version="[1.0,2)"</require>
+    <require name='package' filter='(&amp;(package=org.mozilla.javascript))' extend='false'
multiple='false' optional='false'>Import package org.mozilla.javascript</require>
+    <require name='package' filter='(&amp;(package=org.osgi.service.component)(version&gt;=1.3.0)(!(version&gt;=2.0.0)))'
extend='false' multiple='false' optional='false'>Import package org.osgi.service.component;version="[1.3,2)"</require>
+    <require name='package' filter='(&amp;(package=org.slf4j)(version&gt;=1.7.0)(!(version&gt;=2.0.0)))'
extend='false' multiple='false' optional='false'>Import package org.slf4j;version="[1.7,2)"</require>
+    <require name='ee' filter='(|(ee=JavaSE-1.7))' extend='false' multiple='false' optional='false'>Execution
Environment (|(ee=JavaSE-1.7))</require>
+  </resource>
   <resource id='org.apache.sling.scripting.sightly.js.provider/1.0.14' symbolicname='org.apache.sling.scripting.sightly.js.provider'
presentationname='Apache Sling Scripting HTL JavaScript Use Provider' uri='http://repo1.maven.org/maven2/org/apache/sling/org.apache.sling.scripting.sightly.js.provider-1.0.14.jar'
version='1.0.14'>
     <description>The Apache Sling HTL JavaScript Use Provider adds support for accessing
JS scripts from HTL&apos;s Use-API.</description>
     <size>80363</size>
@@ -12627,16 +12657,16 @@
     <require name='package' filter='(&amp;(package=org.slf4j)(version&gt;=1.5.0)(!(version&gt;=2.0.0)))'
extend='false' multiple='false' optional='false'>Import package org.slf4j;version="[1.5,2)"</require>
     <require name='ee' filter='(|(ee=JavaSE-1.6))' extend='false' multiple='false' optional='false'>Execution
Environment (|(ee=JavaSE-1.6))</require>
   </resource>
-  <resource id='org.apache.sling.scripting.sightly/1.0.0' symbolicname='org.apache.sling.scripting.sightly'
presentationname='Apache Sling Scripting Sightly Engine' uri='http://repo1.maven.org/maven2/org/apache/sling/org.apache.sling.scripting.sightly/1.0.0/org.apache.sling.scripting.sightly-1.0.0.jar'
version='1.0.0'>
+  <resource id='org.apache.sling.scripting.sightly/1.0.12' symbolicname='org.apache.sling.scripting.sightly'
presentationname='Apache Sling Scripting Sightly Engine' uri='http://repo1.maven.org/maven2/org/apache/sling/org.apache.sling.scripting.sightly-1.0.12.jar'
version='1.0.12'>
     <description>The Apache Sling Scripting Sightly Engine is a Java implementation
of the Sightly specification. The bundle contains the Sightly        engine and its plugin
framework implementation.</description>
-    <size>689811</size>
+    <size>690669</size>
     <documentation>http://sling.apache.org</documentation>
     <license>http://www.apache.org/licenses/LICENSE-2.0.txt</license>
     <category id='sling'/>
     <capability name='bundle'>
       <p n='symbolicname' v='org.apache.sling.scripting.sightly'/>
       <p n='presentationname' v='Apache Sling Scripting Sightly Engine'/>
-      <p n='version' t='version' v='1.0.0'/>
+      <p n='version' t='version' v='1.0.12'/>
       <p n='manifestversion' v='2'/>
     </capability>
     <capability name='package'>
@@ -12687,14 +12717,12 @@
     <require name='package' filter='(&amp;(package=org.apache.sling.commons.compiler)(version&gt;=2.0.0)(!(version&gt;=3.0.0)))'
extend='false' multiple='false' optional='false'>Import package org.apache.sling.commons.compiler;version="[2.0,3)"</require>
     <require name='package' filter='(&amp;(package=org.apache.sling.commons.osgi)(version&gt;=2.1.0)(!(version&gt;=3.0.0)))'
extend='false' multiple='false' optional='false'>Import package org.apache.sling.commons.osgi;version="[2.1,3)"</require>
     <require name='package' filter='(&amp;(package=org.apache.sling.i18n)(version&gt;=2.2.0)(!(version&gt;=3.0.0)))'
extend='false' multiple='false' optional='false'>Import package org.apache.sling.i18n;version="[2.2,3)"</require>
-    <require name='package' filter='(&amp;(package=org.apache.sling.jcr.compiler)(version&gt;=2.1.0)(!(version&gt;=3.0.0)))'
extend='false' multiple='false' optional='false'>Import package org.apache.sling.jcr.compiler;version="[2.1,3)"</require>
     <require name='package' filter='(&amp;(package=org.apache.sling.scripting.api)(version&gt;=2.1.0)(!(version&gt;=3.0.0)))'
extend='false' multiple='false' optional='false'>Import package org.apache.sling.scripting.api;version="[2.1,3)"</require>
     <require name='package' filter='(&amp;(package=org.apache.sling.scripting.sightly)(version&gt;=1.0.0)(!(version&gt;=2.0.0)))'
extend='false' multiple='false' optional='false'>Import package org.apache.sling.scripting.sightly;version="[1.0,2)"</require>
     <require name='package' filter='(&amp;(package=org.apache.sling.scripting.sightly.extension)(version&gt;=1.0.0)(!(version&gt;=2.0.0)))'
extend='false' multiple='false' optional='false'>Import package org.apache.sling.scripting.sightly.extension;version="[1.0,2)"</require>
     <require name='package' filter='(&amp;(package=org.apache.sling.scripting.sightly.pojo)(version&gt;=1.0.0)(!(version&gt;=2.0.0)))'
extend='false' multiple='false' optional='false'>Import package org.apache.sling.scripting.sightly.pojo;version="[1.0,2)"</require>
     <require name='package' filter='(&amp;(package=org.apache.sling.scripting.sightly.render)(version&gt;=1.0.0)(!(version&gt;=1.1.0)))'
extend='false' multiple='false' optional='false'>Import package org.apache.sling.scripting.sightly.render;version="[1.0,1.1)"</require>
     <require name='package' filter='(&amp;(package=org.apache.sling.scripting.sightly.use)(version&gt;=1.0.0)(!(version&gt;=2.0.0)))'
extend='false' multiple='false' optional='false'>Import package org.apache.sling.scripting.sightly.use;version="[1.0,2)"</require>
-    <require name='package' filter='(&amp;(package=org.apache.sling.settings)(version&gt;=1.0.0)(!(version&gt;=2.0.0)))'
extend='false' multiple='false' optional='false'>Import package org.apache.sling.settings;version="[1.0,2)"</require>
     <require name='package' filter='(&amp;(package=org.apache.sling.xss)(version&gt;=1.0.0)(!(version&gt;=2.0.0)))'
extend='false' multiple='false' optional='false'>Import package org.apache.sling.xss;version="[1.0,2)"</require>
     <require name='package' filter='(&amp;(package=org.osgi.framework)(version&gt;=1.4.0)(!(version&gt;=2.0.0)))'
extend='false' multiple='false' optional='false'>Import package org.osgi.framework;version="[1.4,2)"</require>
     <require name='package' filter='(&amp;(package=org.osgi.service.component)(version&gt;=1.0.0)(!(version&gt;=2.0.0)))'
extend='false' multiple='false' optional='false'>Import package org.osgi.service.component;version="[1.0,2)"</require>
@@ -12702,16 +12730,16 @@
     <require name='package' filter='(&amp;(package=org.slf4j)(version&gt;=1.5.0)(!(version&gt;=2.0.0)))'
extend='false' multiple='false' optional='false'>Import package org.slf4j;version="[1.5,2)"</require>
     <require name='ee' filter='(|(ee=JavaSE-1.6))' extend='false' multiple='false' optional='false'>Execution
Environment (|(ee=JavaSE-1.6))</require>
   </resource>
-  <resource id='org.apache.sling.scripting.sightly/1.0.12' symbolicname='org.apache.sling.scripting.sightly'
presentationname='Apache Sling Scripting Sightly Engine' uri='http://repo1.maven.org/maven2/org/apache/sling/org.apache.sling.scripting.sightly-1.0.12.jar'
version='1.0.12'>
+  <resource id='org.apache.sling.scripting.sightly/1.0.0' symbolicname='org.apache.sling.scripting.sightly'
presentationname='Apache Sling Scripting Sightly Engine' uri='http://repo1.maven.org/maven2/org/apache/sling/org.apache.sling.scripting.sightly/1.0.0/org.apache.sling.scripting.sightly-1.0.0.jar'
version='1.0.0'>
     <description>The Apache Sling Scripting Sightly Engine is a Java implementation
of the Sightly specification. The bundle contains the Sightly        engine and its plugin
framework implementation.</description>
-    <size>690669</size>
+    <size>689811</size>
     <documentation>http://sling.apache.org</documentation>
     <license>http://www.apache.org/licenses/LICENSE-2.0.txt</license>
     <category id='sling'/>
     <capability name='bundle'>
       <p n='symbolicname' v='org.apache.sling.scripting.sightly'/>
       <p n='presentationname' v='Apache Sling Scripting Sightly Engine'/>
-      <p n='version' t='version' v='1.0.12'/>
+      <p n='version' t='version' v='1.0.0'/>
       <p n='manifestversion' v='2'/>
     </capability>
     <capability name='package'>
@@ -12762,12 +12790,14 @@
     <require name='package' filter='(&amp;(package=org.apache.sling.commons.compiler)(version&gt;=2.0.0)(!(version&gt;=3.0.0)))'
extend='false' multiple='false' optional='false'>Import package org.apache.sling.commons.compiler;version="[2.0,3)"</require>
     <require name='package' filter='(&amp;(package=org.apache.sling.commons.osgi)(version&gt;=2.1.0)(!(version&gt;=3.0.0)))'
extend='false' multiple='false' optional='false'>Import package org.apache.sling.commons.osgi;version="[2.1,3)"</require>
     <require name='package' filter='(&amp;(package=org.apache.sling.i18n)(version&gt;=2.2.0)(!(version&gt;=3.0.0)))'
extend='false' multiple='false' optional='false'>Import package org.apache.sling.i18n;version="[2.2,3)"</require>
+    <require name='package' filter='(&amp;(package=org.apache.sling.jcr.compiler)(version&gt;=2.1.0)(!(version&gt;=3.0.0)))'
extend='false' multiple='false' optional='false'>Import package org.apache.sling.jcr.compiler;version="[2.1,3)"</require>
     <require name='package' filter='(&amp;(package=org.apache.sling.scripting.api)(version&gt;=2.1.0)(!(version&gt;=3.0.0)))'
extend='false' multiple='false' optional='false'>Import package org.apache.sling.scripting.api;version="[2.1,3)"</require>
     <require name='package' filter='(&amp;(package=org.apache.sling.scripting.sightly)(version&gt;=1.0.0)(!(version&gt;=2.0.0)))'
extend='false' multiple='false' optional='false'>Import package org.apache.sling.scripting.sightly;version="[1.0,2)"</require>
     <require name='package' filter='(&amp;(package=org.apache.sling.scripting.sightly.extension)(version&gt;=1.0.0)(!(version&gt;=2.0.0)))'
extend='false' multiple='false' optional='false'>Import package org.apache.sling.scripting.sightly.extension;version="[1.0,2)"</require>
     <require name='package' filter='(&amp;(package=org.apache.sling.scripting.sightly.pojo)(version&gt;=1.0.0)(!(version&gt;=2.0.0)))'
extend='false' multiple='false' optional='false'>Import package org.apache.sling.scripting.sightly.pojo;version="[1.0,2)"</require>
     <require name='package' filter='(&amp;(package=org.apache.sling.scripting.sightly.render)(version&gt;=1.0.0)(!(version&gt;=1.1.0)))'
extend='false' multiple='false' optional='false'>Import package org.apache.sling.scripting.sightly.render;version="[1.0,1.1)"</require>
     <require name='package' filter='(&amp;(package=org.apache.sling.scripting.sightly.use)(version&gt;=1.0.0)(!(version&gt;=2.0.0)))'
extend='false' multiple='false' optional='false'>Import package org.apache.sling.scripting.sightly.use;version="[1.0,2)"</require>
+    <require name='package' filter='(&amp;(package=org.apache.sling.settings)(version&gt;=1.0.0)(!(version&gt;=2.0.0)))'
extend='false' multiple='false' optional='false'>Import package org.apache.sling.settings;version="[1.0,2)"</require>
     <require name='package' filter='(&amp;(package=org.apache.sling.xss)(version&gt;=1.0.0)(!(version&gt;=2.0.0)))'
extend='false' multiple='false' optional='false'>Import package org.apache.sling.xss;version="[1.0,2)"</require>
     <require name='package' filter='(&amp;(package=org.osgi.framework)(version&gt;=1.4.0)(!(version&gt;=2.0.0)))'
extend='false' multiple='false' optional='false'>Import package org.osgi.framework;version="[1.4,2)"</require>
     <require name='package' filter='(&amp;(package=org.osgi.service.component)(version&gt;=1.0.0)(!(version&gt;=2.0.0)))'
extend='false' multiple='false' optional='false'>Import package org.osgi.service.component;version="[1.0,2)"</require>



Mime
View raw message