sling-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From r...@apache.org
Subject svn commit: r1695718 - in /sling/site/trunk/content: downloads.list news.mdtext obr/sling.xml
Date Thu, 13 Aug 2015 14:35:57 GMT
Author: radu
Date: Thu Aug 13 14:35:57 2015
New Revision: 1695718

URL: http://svn.apache.org/r1695718
Log:
Added Apache Sling Scripting Core 2.0.34, Apache Sling Scripting JavaScript 2.0.22

Modified:
    sling/site/trunk/content/downloads.list
    sling/site/trunk/content/news.mdtext
    sling/site/trunk/content/obr/sling.xml

Modified: sling/site/trunk/content/downloads.list
URL: http://svn.apache.org/viewvc/sling/site/trunk/content/downloads.list?rev=1695718&r1=1695717&r2=1695718&view=diff
==============================================================================
--- sling/site/trunk/content/downloads.list (original)
+++ sling/site/trunk/content/downloads.list Thu Aug 13 14:35:57 2015
@@ -132,9 +132,9 @@ Sample Integration Tests|org.apache.slin
 Sample Server-Side Tests|org.apache.sling.testing.samples.sampletests|1.0.6
 Scripting API|org.apache.sling.scripting.api|2.1.8
 Scripting Console|org.apache.sling.scripting.console|1.0.0
-Scripting Core|org.apache.sling.scripting.core|2.0.32
+Scripting Core|org.apache.sling.scripting.core|2.0.34
 Scripting Java|org.apache.sling.scripting.java|2.0.12
-Scripting JavaScript|org.apache.sling.scripting.javascript|2.0.20
+Scripting JavaScript|org.apache.sling.scripting.javascript|2.0.22
 Scripting JSP|org.apache.sling.scripting.jsp|2.1.6
 Scripting JSP Taglib|org.apache.sling.scripting.jsp.taglib|2.2.4
 Scripting JST|org.apache.sling.scripting.jst|2.0.6

Modified: sling/site/trunk/content/news.mdtext
URL: http://svn.apache.org/viewvc/sling/site/trunk/content/news.mdtext?rev=1695718&r1=1695717&r2=1695718&view=diff
==============================================================================
--- sling/site/trunk/content/news.mdtext (original)
+++ sling/site/trunk/content/news.mdtext Thu Aug 13 14:35:57 2015
@@ -1,5 +1,6 @@
 Title: News
 
+* New Releases: Apache Sling Scripting Core 2.0.34, Apache Sling Scripting JavaScript 2.0.22
(August 13th, 2015)
 * New Release: Apache Sling i18n 2.4.4 (August 13th, 2015)
 * New Releases: Apache Sling Commons Log 4.0.6 (August 11th, 2015)
 * New Releases: Apache Sling Slingstart Maven Plugin 1.3.0, and Apache Sling Provisioning
Model 1.3.0 (August 7th, 2015)

Modified: sling/site/trunk/content/obr/sling.xml
URL: http://svn.apache.org/viewvc/sling/site/trunk/content/obr/sling.xml?rev=1695718&r1=1695717&r2=1695718&view=diff
==============================================================================
--- sling/site/trunk/content/obr/sling.xml (original)
+++ sling/site/trunk/content/obr/sling.xml Thu Aug 13 14:35:57 2015
@@ -1,4 +1,4 @@
-<repository name='Apache Sling Release Repository' lastmodified='20150803015247.441'>
+<repository name='Apache Sling Release Repository' lastmodified='20150813043528.616'>
   <resource id='org.apache.sling.extensions.classloader-leak-detector/1.0.0' symbolicname='org.apache.sling.extensions.classloader-leak-detector'
presentationname='Adobe Sling ClassLoader Leak Detector' uri='http://repo1.maven.org/maven2/org/apache/sling/org.apache.sling.extensions.classloader-leak-detector/1.0.0/org.apache.sling.extensions.classloader-leak-detector-1.0.0.jar'
version='1.0.0'>
     <description>Provides a web console configuration printer to provide details around
classloader leaks</description>
     <size>18203</size>
@@ -6483,6 +6483,50 @@
     <require name='package' filter='(&amp;(package=org.slf4j)(version&gt;=1.5.0)(!(version&gt;=2.0.0)))'
extend='false' multiple='false' optional='false'>Import package org.slf4j;version="[1.5,2)"</require>
     <require name='ee' filter='(|(ee=JavaSE-1.6))' extend='false' multiple='false' optional='false'>Execution
Environment (|(ee=JavaSE-1.6))</require>
   </resource>
+  <resource id='org.apache.sling.scripting.core/2.0.34' symbolicname='org.apache.sling.scripting.core'
presentationname='Apache Sling Scripting Core implementation' uri='http://repo1.maven.org/maven2/org/apache/sling/org.apache.sling.scripting.core-2.0.34.jar'
version='2.0.34'>
+    <description>Sling Scripting core functionality</description>
+    <size>82469</size>
+    <documentation>http://sling.apache.org</documentation>
+    <license>http://www.apache.org/licenses/LICENSE-2.0.txt</license>
+    <category id='sling'/>
+    <capability name='bundle'>
+      <p n='symbolicname' v='org.apache.sling.scripting.core'/>
+      <p n='presentationname' v='Apache Sling Scripting Core implementation'/>
+      <p n='version' t='version' v='2.0.34'/>
+      <p n='manifestversion' v='2'/>
+    </capability>
+    <capability name='package'>
+      <p n='package' v='org.apache.sling.scripting.core'/>
+      <p n='version' t='version' v='2.1.0'/>
+      <p n='uses:' v='org.apache.sling.api,org.apache.sling.api.request,org.apache.sling.api.resource,org.apache.sling.api.scripting,org.apache.sling.scripting.api,org.osgi.framework'/>
+    </capability>
+    <capability name='package'>
+      <p n='package' v='org.apache.sling.scripting.core.servlet'/>
+      <p n='version' t='version' v='1.0.0'/>
+      <p n='uses:' v='javax.servlet,javax.servlet.http'/>
+    </capability>
+    <require name='package' filter='(&amp;(package=javax.script))' extend='false'
multiple='false' optional='false'>Import package javax.script</require>
+    <require name='package' filter='(&amp;(package=javax.servlet))' extend='false'
multiple='false' optional='false'>Import package javax.servlet</require>
+    <require name='package' filter='(&amp;(package=javax.servlet.http))' extend='false'
multiple='false' optional='false'>Import package javax.servlet.http</require>
+    <require name='package' filter='(&amp;(package=org.apache.commons.io)(version&gt;=1.4.0)(!(version&gt;=2.0.0)))'
extend='false' multiple='false' optional='false'>Import package org.apache.commons.io;version="[1.4,2)"</require>
+    <require name='package' filter='(&amp;(package=org.apache.commons.lang)(version&gt;=2.4.0)(!(version&gt;=3.0.0)))'
extend='false' multiple='false' optional='false'>Import package org.apache.commons.lang;version="[2.4,3)"</require>
+    <require name='package' filter='(&amp;(package=org.apache.felix.webconsole)(version&gt;=3.1.0)(!(version&gt;=4.0.0)))'
extend='false' multiple='false' optional='false'>Import package org.apache.felix.webconsole;version="[3.1,4)"</require>
+    <require name='package' filter='(&amp;(package=org.apache.sling.api)(version&gt;=2.1.0)(!(version&gt;=3.0.0)))'
extend='false' multiple='false' optional='false'>Import package org.apache.sling.api;version="[2.1,3)"</require>
+    <require name='package' filter='(&amp;(package=org.apache.sling.api.adapter)(version&gt;=2.1.0)(!(version&gt;=3.0.0)))'
extend='false' multiple='false' optional='false'>Import package org.apache.sling.api.adapter;version="[2.1,3)"</require>
+    <require name='package' filter='(&amp;(package=org.apache.sling.api.request)(version&gt;=2.1.0)(!(version&gt;=3.0.0)))'
extend='false' multiple='false' optional='false'>Import package org.apache.sling.api.request;version="[2.1,3)"</require>
+    <require name='package' filter='(&amp;(package=org.apache.sling.api.resource)(version&gt;=2.1.0)(!(version&gt;=3.0.0)))'
extend='false' multiple='false' optional='false'>Import package org.apache.sling.api.resource;version="[2.1,3)"</require>
+    <require name='package' filter='(&amp;(package=org.apache.sling.api.scripting)(version&gt;=2.1.0)(!(version&gt;=3.0.0)))'
extend='false' multiple='false' optional='false'>Import package org.apache.sling.api.scripting;version="[2.1,3)"</require>
+    <require name='package' filter='(&amp;(package=org.apache.sling.api.wrappers)(version&gt;=2.1.0)(!(version&gt;=3.0.0)))'
extend='false' multiple='false' optional='false'>Import package org.apache.sling.api.wrappers;version="[2.1,3)"</require>
+    <require name='package' filter='(&amp;(package=org.apache.sling.commons.mime)(version&gt;=2.0.0)(!(version&gt;=3.0.0)))'
extend='false' multiple='false' optional='false'>Import package org.apache.sling.commons.mime;version="[2.0,3)"</require>
+    <require name='package' filter='(&amp;(package=org.apache.sling.commons.threads)(version&gt;=3.1.0)(!(version&gt;=4.0.0)))'
extend='false' multiple='false' optional='false'>Import package org.apache.sling.commons.threads;version="[3.1,4)"</require>
+    <require name='package' filter='(&amp;(package=org.apache.sling.scripting.api)(version&gt;=2.3.0)(!(version&gt;=3.0.0)))'
extend='false' multiple='false' optional='false'>Import package org.apache.sling.scripting.api;version="[2.3,3)"</require>
+    <require name='package' filter='(&amp;(package=org.osgi.framework)(version&gt;=1.5.0)(!(version&gt;=2.0.0)))'
extend='false' multiple='false' optional='false'>Import package org.osgi.framework;version="[1.5,2)"</require>
+    <require name='package' filter='(&amp;(package=org.osgi.service.component)(version&gt;=1.1.0)(!(version&gt;=2.0.0)))'
extend='false' multiple='false' optional='false'>Import package org.osgi.service.component;version="[1.1,2)"</require>
+    <require name='package' filter='(&amp;(package=org.osgi.service.event)(version&gt;=1.2.0)(!(version&gt;=2.0.0)))'
extend='false' multiple='false' optional='false'>Import package org.osgi.service.event;version="[1.2,2)"</require>
+    <require name='package' filter='(&amp;(package=org.osgi.util.tracker)(version&gt;=1.4.0)(!(version&gt;=2.0.0)))'
extend='false' multiple='false' optional='false'>Import package org.osgi.util.tracker;version="[1.4,2)"</require>
+    <require name='package' filter='(&amp;(package=org.slf4j)(version&gt;=1.5.0)(!(version&gt;=2.0.0)))'
extend='false' multiple='false' optional='false'>Import package org.slf4j;version="[1.5,2)"</require>
+    <require name='ee' filter='(|(ee=JavaSE-1.6))' extend='false' multiple='false' optional='false'>Execution
Environment (|(ee=JavaSE-1.6))</require>
+  </resource>
   <resource id='org.apache.sling.scripting.core/2.0.4.incubator' symbolicname='org.apache.sling.scripting.core'
presentationname='Apache Sling Scripting Core implementation' uri='http://repo1.maven.org/maven2/org/apache/sling/org.apache.sling.scripting.core/2.0.4.incubator/org.apache.sling.scripting.core-2.0.4.incubator.jar'
version='2.0.4.incubator'>
     <description>Sling Scripting core functionality</description>
     <size>33878</size>
@@ -6816,6 +6860,73 @@
       <p n='manifestversion' v='2'/>
     </capability>
     <capability name='package'>
+      <p n='package' v='org.apache.sling.scripting.javascript'/>
+      <p n='version' t='version' v='0.1.0'/>
+      <p n='uses:' v='org.mozilla.javascript'/>
+    </capability>
+    <capability name='package'>
+      <p n='package' v='org.mozilla.javascript'/>
+      <p n='version' t='version' v='1.0.0'/>
+      <p n='uses:' v='org.mozilla.javascript.debug'/>
+    </capability>
+    <capability name='package'>
+      <p n='package' v='org.mozilla.classfile'/>
+      <p n='version' t='version' v='0.0.1'/>
+    </capability>
+    <capability name='package'>
+      <p n='package' v='org.mozilla.javascript.debug'/>
+      <p n='version' t='version' v='0.0.1'/>
+      <p n='uses:' v='org.mozilla.javascript'/>
+    </capability>
+    <require name='package' filter='(&amp;(package=javax.jcr)(version&gt;=2.0.0))'
extend='false' multiple='false' optional='false'>Import package javax.jcr;version=2.0</require>
+    <require name='package' filter='(&amp;(package=javax.jcr.lock)(version&gt;=2.0.0))'
extend='false' multiple='false' optional='false'>Import package javax.jcr.lock;version=2.0</require>
+    <require name='package' filter='(&amp;(package=javax.jcr.nodetype)(version&gt;=2.0.0))'
extend='false' multiple='false' optional='false'>Import package javax.jcr.nodetype;version=2.0</require>
+    <require name='package' filter='(&amp;(package=javax.jcr.version)(version&gt;=2.0.0))'
extend='false' multiple='false' optional='false'>Import package javax.jcr.version;version=2.0</require>
+    <require name='package' filter='(&amp;(package=javax.script))' extend='false'
multiple='false' optional='false'>Import package javax.script</require>
+    <require name='package' filter='(&amp;(package=javax.servlet.http))' extend='false'
multiple='false' optional='false'>Import package javax.servlet.http</require>
+    <require name='package' filter='(&amp;(package=javax.swing))' extend='false' multiple='false'
optional='false'>Import package javax.swing</require>
+    <require name='package' filter='(&amp;(package=javax.swing.border))' extend='false'
multiple='false' optional='false'>Import package javax.swing.border</require>
+    <require name='package' filter='(&amp;(package=javax.swing.event))' extend='false'
multiple='false' optional='false'>Import package javax.swing.event</require>
+    <require name='package' filter='(&amp;(package=javax.swing.filechooser))' extend='false'
multiple='false' optional='false'>Import package javax.swing.filechooser</require>
+    <require name='package' filter='(&amp;(package=javax.swing.table))' extend='false'
multiple='false' optional='false'>Import package javax.swing.table</require>
+    <require name='package' filter='(&amp;(package=javax.swing.text))' extend='false'
multiple='false' optional='false'>Import package javax.swing.text</require>
+    <require name='package' filter='(&amp;(package=javax.swing.tree))' extend='false'
multiple='false' optional='false'>Import package javax.swing.tree</require>
+    <require name='package' filter='(&amp;(package=javax.xml.parsers))' extend='false'
multiple='false' optional='false'>Import package javax.xml.parsers</require>
+    <require name='package' filter='(&amp;(package=javax.xml.transform))' extend='false'
multiple='false' optional='false'>Import package javax.xml.transform</require>
+    <require name='package' filter='(&amp;(package=javax.xml.transform.dom))' extend='false'
multiple='false' optional='false'>Import package javax.xml.transform.dom</require>
+    <require name='package' filter='(&amp;(package=javax.xml.transform.stream))' extend='false'
multiple='false' optional='false'>Import package javax.xml.transform.stream</require>
+    <require name='package' filter='(&amp;(package=org.apache.commons.collections)(version&gt;=3.2.0)(!(version&gt;=4.0.0)))'
extend='false' multiple='false' optional='false'>Import package org.apache.commons.collections;version="[3.2,4)"</require>
+    <require name='package' filter='(&amp;(package=org.apache.commons.io)(version&gt;=1.4.0)(!(version&gt;=2.0.0)))'
extend='false' multiple='false' optional='false'>Import package org.apache.commons.io;version="[1.4,2)"</require>
+    <require name='package' filter='(&amp;(package=org.apache.sling.api.resource)(version&gt;=2.1.0)(!(version&gt;=3.0.0)))'
extend='false' multiple='false' optional='false'>Import package org.apache.sling.api.resource;version="[2.1,3)"</require>
+    <require name='package' filter='(&amp;(package=org.apache.sling.api.scripting)(version&gt;=2.1.0)(!(version&gt;=3.0.0)))'
extend='false' multiple='false' optional='false'>Import package org.apache.sling.api.scripting;version="[2.1,3)"</require>
+    <require name='package' filter='(&amp;(package=org.apache.sling.commons.classloader)(version&gt;=1.3.0)(!(version&gt;=2.0.0)))'
extend='false' multiple='false' optional='false'>Import package org.apache.sling.commons.classloader;version="[1.3,2)"</require>
+    <require name='package' filter='(&amp;(package=org.apache.sling.commons.json.jcr)(version&gt;=2.0.0)(!(version&gt;=3.0.0)))'
extend='false' multiple='false' optional='false'>Import package org.apache.sling.commons.json.jcr;version="[2.0,3)"</require>
+    <require name='package' filter='(&amp;(package=org.apache.sling.jcr.resource)(version&gt;=2.2.0)(!(version&gt;=3.0.0)))'
extend='false' multiple='false' optional='false'>Import package org.apache.sling.jcr.resource;version="[2.2,3)"</require>
+    <require name='package' filter='(&amp;(package=org.apache.sling.scripting.api)(version&gt;=2.3.0)(!(version&gt;=3.0.0)))'
extend='false' multiple='false' optional='false'>Import package org.apache.sling.scripting.api;version="[2.3,3)"</require>
+    <require name='package' filter='(&amp;(package=org.apache.sling.scripting.core)(version&gt;=2.1.0)(!(version&gt;=3.0.0)))'
extend='false' multiple='false' optional='false'>Import package org.apache.sling.scripting.core;version="[2.1,3)"</require>
+    <require name='package' filter='(&amp;(package=org.apache.sling.scripting.javascript)(version&gt;=0.1.0)(!(version&gt;=1.0.0)))'
extend='false' multiple='false' optional='false'>Import package org.apache.sling.scripting.javascript;version="[0.1,1)"</require>
+    <require name='package' filter='(&amp;(package=org.mozilla.classfile)(!(version&gt;=1.0.0)))'
extend='false' multiple='false' optional='false'>Import package org.mozilla.classfile;version="[0.0,1)"</require>
+    <require name='package' filter='(&amp;(package=org.mozilla.javascript.debug)(!(version&gt;=1.0.0)))'
extend='false' multiple='false' optional='false'>Import package org.mozilla.javascript.debug;version="[0.0,1)"</require>
+    <require name='package' filter='(&amp;(package=org.osgi.framework)(version&gt;=1.4.0)(!(version&gt;=2.0.0)))'
extend='false' multiple='false' optional='false'>Import package org.osgi.framework;version="[1.4,2)"</require>
+    <require name='package' filter='(&amp;(package=org.osgi.service.component)(version&gt;=1.0.0)(!(version&gt;=2.0.0)))'
extend='false' multiple='false' optional='false'>Import package org.osgi.service.component;version="[1.0,2)"</require>
+    <require name='package' filter='(&amp;(package=org.slf4j)(version&gt;=1.5.0)(!(version&gt;=2.0.0)))'
extend='false' multiple='false' optional='false'>Import package org.slf4j;version="[1.5,2)"</require>
+    <require name='package' filter='(&amp;(package=org.w3c.dom))' extend='false' multiple='false'
optional='false'>Import package org.w3c.dom</require>
+    <require name='package' filter='(&amp;(package=org.xml.sax))' extend='false' multiple='false'
optional='false'>Import package org.xml.sax</require>
+    <require name='ee' filter='(|(ee=JavaSE-1.6))' extend='false' multiple='false' optional='false'>Execution
Environment (|(ee=JavaSE-1.6))</require>
+  </resource>
+  <resource id='org.apache.sling.scripting.javascript/2.0.22' symbolicname='org.apache.sling.scripting.javascript'
presentationname='Apache Sling Scripting JavaScript Support' uri='http://repo1.maven.org/maven2/org/apache/sling/org.apache.sling.scripting.javascript-2.0.22.jar'
version='2.0.22'>
+    <description>Support for JavaScript scripting</description>
+    <size>1332905</size>
+    <documentation>http://sling.apache.org</documentation>
+    <license>http://www.apache.org/licenses/LICENSE-2.0.txt</license>
+    <category id='sling'/>
+    <capability name='bundle'>
+      <p n='symbolicname' v='org.apache.sling.scripting.javascript'/>
+      <p n='presentationname' v='Apache Sling Scripting JavaScript Support'/>
+      <p n='version' t='version' v='2.0.22'/>
+      <p n='manifestversion' v='2'/>
+    </capability>
+    <capability name='package'>
       <p n='package' v='org.apache.sling.scripting.javascript'/>
       <p n='version' t='version' v='0.1.0'/>
       <p n='uses:' v='org.mozilla.javascript'/>



Mime
View raw message