sling-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From r...@apache.org
Subject svn commit: r1692723 - /sling/site/trunk/content/obr/sling.xml
Date Sun, 26 Jul 2015 12:33:46 GMT
Author: radu
Date: Sun Jul 26 12:33:46 2015
New Revision: 1692723

URL: http://svn.apache.org/r1692723
Log:
Added Apache Sling Scripting Core 2.0.32

Modified:
    sling/site/trunk/content/obr/sling.xml

Modified: sling/site/trunk/content/obr/sling.xml
URL: http://svn.apache.org/viewvc/sling/site/trunk/content/obr/sling.xml?rev=1692723&r1=1692722&r2=1692723&view=diff
==============================================================================
--- sling/site/trunk/content/obr/sling.xml (original)
+++ sling/site/trunk/content/obr/sling.xml Sun Jul 26 12:33:46 2015
@@ -1,4 +1,4 @@
-<repository name='Apache Sling Release Repository' lastmodified='20150721025545.054'>
+<repository name='Apache Sling Release Repository' lastmodified='20150726023303.046'>
   <resource id='org.apache.sling.extensions.classloader-leak-detector/1.0.0' symbolicname='org.apache.sling.extensions.classloader-leak-detector'
presentationname='Adobe Sling ClassLoader Leak Detector' uri='http://repo1.maven.org/maven2/org/apache/sling/org.apache.sling.extensions.classloader-leak-detector-1.0.0.jar'
version='1.0.0'>
     <description>Provides a web console configuration printer to provide details around
classloader leaks</description>
     <size>18203</size>
@@ -5637,6 +5637,50 @@
       <p n='manifestversion' v='2'/>
     </capability>
     <capability name='package'>
+      <p n='package' v='org.apache.sling.scripting.core'/>
+      <p n='version' t='version' v='2.1.0'/>
+      <p n='uses:' v='org.apache.sling.api,org.apache.sling.api.request,org.apache.sling.api.resource,org.apache.sling.api.scripting,org.apache.sling.scripting.api,org.osgi.framework'/>
+    </capability>
+    <capability name='package'>
+      <p n='package' v='org.apache.sling.scripting.core.servlet'/>
+      <p n='version' t='version' v='1.0.0'/>
+      <p n='uses:' v='javax.servlet,javax.servlet.http'/>
+    </capability>
+    <require name='package' filter='(&amp;(package=javax.script))' extend='false'
multiple='false' optional='false'>Import package javax.script</require>
+    <require name='package' filter='(&amp;(package=javax.servlet))' extend='false'
multiple='false' optional='false'>Import package javax.servlet</require>
+    <require name='package' filter='(&amp;(package=javax.servlet.http))' extend='false'
multiple='false' optional='false'>Import package javax.servlet.http</require>
+    <require name='package' filter='(&amp;(package=org.apache.commons.io)(version&gt;=1.4.0)(!(version&gt;=2.0.0)))'
extend='false' multiple='false' optional='false'>Import package org.apache.commons.io;version="[1.4,2)"</require>
+    <require name='package' filter='(&amp;(package=org.apache.commons.lang)(version&gt;=2.4.0)(!(version&gt;=3.0.0)))'
extend='false' multiple='false' optional='false'>Import package org.apache.commons.lang;version="[2.4,3)"</require>
+    <require name='package' filter='(&amp;(package=org.apache.felix.webconsole)(version&gt;=3.1.0)(!(version&gt;=4.0.0)))'
extend='false' multiple='false' optional='false'>Import package org.apache.felix.webconsole;version="[3.1,4)"</require>
+    <require name='package' filter='(&amp;(package=org.apache.sling.api)(version&gt;=2.1.0)(!(version&gt;=3.0.0)))'
extend='false' multiple='false' optional='false'>Import package org.apache.sling.api;version="[2.1,3)"</require>
+    <require name='package' filter='(&amp;(package=org.apache.sling.api.adapter)(version&gt;=2.1.0)(!(version&gt;=3.0.0)))'
extend='false' multiple='false' optional='false'>Import package org.apache.sling.api.adapter;version="[2.1,3)"</require>
+    <require name='package' filter='(&amp;(package=org.apache.sling.api.request)(version&gt;=2.1.0)(!(version&gt;=3.0.0)))'
extend='false' multiple='false' optional='false'>Import package org.apache.sling.api.request;version="[2.1,3)"</require>
+    <require name='package' filter='(&amp;(package=org.apache.sling.api.resource)(version&gt;=2.1.0)(!(version&gt;=3.0.0)))'
extend='false' multiple='false' optional='false'>Import package org.apache.sling.api.resource;version="[2.1,3)"</require>
+    <require name='package' filter='(&amp;(package=org.apache.sling.api.scripting)(version&gt;=2.1.0)(!(version&gt;=3.0.0)))'
extend='false' multiple='false' optional='false'>Import package org.apache.sling.api.scripting;version="[2.1,3)"</require>
+    <require name='package' filter='(&amp;(package=org.apache.sling.api.wrappers)(version&gt;=2.1.0)(!(version&gt;=3.0.0)))'
extend='false' multiple='false' optional='false'>Import package org.apache.sling.api.wrappers;version="[2.1,3)"</require>
+    <require name='package' filter='(&amp;(package=org.apache.sling.commons.mime)(version&gt;=2.0.0)(!(version&gt;=3.0.0)))'
extend='false' multiple='false' optional='false'>Import package org.apache.sling.commons.mime;version="[2.0,3)"</require>
+    <require name='package' filter='(&amp;(package=org.apache.sling.commons.threads)(version&gt;=3.1.0)(!(version&gt;=4.0.0)))'
extend='false' multiple='false' optional='false'>Import package org.apache.sling.commons.threads;version="[3.1,4)"</require>
+    <require name='package' filter='(&amp;(package=org.apache.sling.scripting.api)(version&gt;=2.3.0)(!(version&gt;=3.0.0)))'
extend='false' multiple='false' optional='false'>Import package org.apache.sling.scripting.api;version="[2.3,3)"</require>
+    <require name='package' filter='(&amp;(package=org.osgi.framework)(version&gt;=1.5.0)(!(version&gt;=2.0.0)))'
extend='false' multiple='false' optional='false'>Import package org.osgi.framework;version="[1.5,2)"</require>
+    <require name='package' filter='(&amp;(package=org.osgi.service.component)(version&gt;=1.1.0)(!(version&gt;=2.0.0)))'
extend='false' multiple='false' optional='false'>Import package org.osgi.service.component;version="[1.1,2)"</require>
+    <require name='package' filter='(&amp;(package=org.osgi.service.event)(version&gt;=1.2.0)(!(version&gt;=2.0.0)))'
extend='false' multiple='false' optional='false'>Import package org.osgi.service.event;version="[1.2,2)"</require>
+    <require name='package' filter='(&amp;(package=org.osgi.util.tracker)(version&gt;=1.4.0)(!(version&gt;=2.0.0)))'
extend='false' multiple='false' optional='false'>Import package org.osgi.util.tracker;version="[1.4,2)"</require>
+    <require name='package' filter='(&amp;(package=org.slf4j)(version&gt;=1.5.0)(!(version&gt;=2.0.0)))'
extend='false' multiple='false' optional='false'>Import package org.slf4j;version="[1.5,2)"</require>
+    <require name='ee' filter='(|(ee=JavaSE-1.6))' extend='false' multiple='false' optional='false'>Execution
Environment (|(ee=JavaSE-1.6))</require>
+  </resource>
+  <resource id='org.apache.sling.scripting.core/2.0.32' symbolicname='org.apache.sling.scripting.core'
presentationname='Apache Sling Scripting Core implementation' uri='http://repo1.maven.org/maven2/org/apache/sling/org.apache.sling.scripting.core-2.0.32.jar'
version='2.0.32'>
+    <description>Sling Scripting core functionality</description>
+    <size>82173</size>
+    <documentation>http://sling.apache.org</documentation>
+    <license>http://www.apache.org/licenses/LICENSE-2.0.txt</license>
+    <category id='sling'/>
+    <capability name='bundle'>
+      <p n='symbolicname' v='org.apache.sling.scripting.core'/>
+      <p n='presentationname' v='Apache Sling Scripting Core implementation'/>
+      <p n='version' t='version' v='2.0.32'/>
+      <p n='manifestversion' v='2'/>
+    </capability>
+    <capability name='package'>
       <p n='package' v='org.apache.sling.scripting.core'/>
       <p n='version' t='version' v='2.1.0'/>
       <p n='uses:' v='org.apache.sling.api,org.apache.sling.api.request,org.apache.sling.api.resource,org.apache.sling.api.scripting,org.apache.sling.scripting.api,org.osgi.framework'/>



Mime
View raw message