sling-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From chet...@apache.org
Subject svn commit: r1652924 - /sling/site/trunk/content/obr/sling.xml
Date Mon, 19 Jan 2015 06:58:38 GMT
Author: chetanm
Date: Mon Jan 19 06:58:38 2015
New Revision: 1652924

URL: http://svn.apache.org/r1652924
Log:
Updating for Sling Datasource 1.0.0 release

Modified:
    sling/site/trunk/content/obr/sling.xml

Modified: sling/site/trunk/content/obr/sling.xml
URL: http://svn.apache.org/viewvc/sling/site/trunk/content/obr/sling.xml?rev=1652924&r1=1652923&r2=1652924&view=diff
==============================================================================
--- sling/site/trunk/content/obr/sling.xml (original)
+++ sling/site/trunk/content/obr/sling.xml Mon Jan 19 06:58:38 2015
@@ -1,4 +1,4 @@
-<repository name='Apache Sling Release Repository' lastmodified='20141215032445.002'>
+<repository name='Apache Sling Release Repository' lastmodified='20150119122138.925'>
   <resource id='org.apache.sling.adapter/2.1.2' symbolicname='org.apache.sling.adapter'
presentationname='Apache Sling Adapter Manager Implementation' uri='http://repo1.maven.org/maven2/org/apache/sling/org.apache.sling.adapter-2.1.2.jar'
version='2.1.2'>
     <description>Bundle implementing the AdapterManager and provides a convenience
       implementation of the Adaptable interface to make use of this        AdapterManager.</description>
     <size>26558</size>
@@ -4651,4 +4651,26 @@
     <require name='package' filter='(&amp;(package=org.slf4j)(version&gt;=1.5.0)(!(version&gt;=2.0.0)))'
extend='false' multiple='false' optional='false'>Import package org.slf4j;version="[1.5,2)"</require>
     <require name='ee' filter='(|(ee=JavaSE-1.6))' extend='false' multiple='false' optional='false'>Execution
Environment (|(ee=JavaSE-1.6))</require>
   </resource>
+  <resource id='org.apache.sling.datasource/1.0.0' symbolicname='org.apache.sling.datasource'
presentationname='Apache Sling DataSource Provider' uri='http://repo1.maven.org/maven2/org/apache/sling/org.apache.sling.datasource/1.0.0/org.apache.sling.datasource-1.0.0.jar'
version='1.0.0'>
+    <description>Enables creation of DataSource based on OSGi configuration</description>
+    <size>167413</size>
+    <documentation>http://sling.apache.org</documentation>
+    <license>http://www.apache.org/licenses/LICENSE-2.0.txt</license>
+    <category id='sling'/>
+    <capability name='bundle'>
+      <p n='symbolicname' v='org.apache.sling.datasource'/>
+      <p n='presentationname' v='Apache Sling DataSource Provider'/>
+      <p n='version' t='version' v='1.0.0'/>
+      <p n='manifestversion' v='2'/>
+    </capability>
+    <require name='package' filter='(&amp;(package=javax.management))' extend='false'
multiple='false' optional='false'>Import package javax.management</require>
+    <require name='package' filter='(&amp;(package=javax.management.openmbean))' extend='false'
multiple='false' optional='false'>Import package javax.management.openmbean</require>
+    <require name='package' filter='(&amp;(package=javax.naming))' extend='false'
multiple='false' optional='false'>Import package javax.naming</require>
+    <require name='package' filter='(&amp;(package=javax.naming.spi))' extend='false'
multiple='false' optional='false'>Import package javax.naming.spi</require>
+    <require name='package' filter='(&amp;(package=javax.sql))' extend='false' multiple='false'
optional='false'>Import package javax.sql</require>
+    <require name='package' filter='(&amp;(package=org.osgi.framework)(version&gt;=1.6.0)(!(version&gt;=2.0.0)))'
extend='false' multiple='false' optional='false'>Import package org.osgi.framework;version="[1.6,2)"</require>
+    <require name='package' filter='(&amp;(package=org.osgi.util.tracker)(version&gt;=1.5.0)(!(version&gt;=2.0.0)))'
extend='false' multiple='false' optional='false'>Import package org.osgi.util.tracker;version="[1.5,2)"</require>
+    <require name='package' filter='(&amp;(package=org.slf4j)(version&gt;=1.5.0)(!(version&gt;=2.0.0)))'
extend='false' multiple='false' optional='false'>Import package org.slf4j;version="[1.5,2)"</require>
+    <require name='ee' filter='(|(ee=JavaSE-1.6))' extend='false' multiple='false' optional='false'>Execution
Environment (|(ee=JavaSE-1.6))</require>
+  </resource>
 </repository>
\ No newline at end of file



Mime
View raw message