sis-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Emmanuel Blondel <emmanuel.blond...@gmail.com>
Subject Re: Question about TimePeriod & auto-generated id
Date Mon, 23 Feb 2015 14:06:32 GMT
Hi Martin,

Thanks for this. I've tested using the code modified with the patch.
Since i was relying on Geotk 4.x-SNAPSHOT, i was using 
0.5-jdk7-SNAPSHOT, which i've excluded as maven dep to use the built jar 
sis-utility

Since i'm producing metadata using information retrieved from a WFS 
data, see the log i get (dealing with JAXB feature type stuff)..
I'm not sure if i'm using well these new deps, should i use all apache 
sis 0.5 deps? or only sis-utility should work?

Exception in thread "main" java.lang.NoSuchFieldError: NAMES
     at org.geotoolkit.feature.type.DefaultName.<init>(DefaultName.java:103)
     at org.geotoolkit.feature.type.DefaultName.<init>(DefaultName.java:89)
     at org.geotoolkit.feature.xml.Utils.<clinit>(Utils.java:88)
     at 
org.geotoolkit.feature.xml.jaxb.JAXBFeatureTypeReader.listAllSchemas(JAXBFeatureTypeReader.java:416)
     at 
org.geotoolkit.feature.xml.jaxb.JAXBFeatureTypeReader.getAllFeatureTypeFromSchema(JAXBFeatureTypeReader.java:404)
     at 
org.geotoolkit.feature.xml.jaxb.JAXBFeatureTypeReader.read(JAXBFeatureTypeReader.java:310)
     at 
org.geotoolkit.feature.xml.jaxb.JAXBFeatureTypeReader.read(JAXBFeatureTypeReader.java:248)



Le 13/02/2015 11:31, Martin Desruisseaux a écrit :
>
> Hello Emmanuel
>
> Le 13/02/15 01:22, Emmanuel Blondel a écrit :
>> Indeed, this is what i was trying.. with 3.2 and 3.2.0, it still 
>> gives http://www.opengis.net/gml/3.2
>
> It is probably a bug. Could you try to download the source code, apply 
> the patch attached to this email and try again please?
>
>   * Download link:
>     http://www.apache.org/dyn/closer.cgi/sis/0.5/apache-sis-0.5-src.zip
>   * Something like the following commands in a Unix shell should work:
>
>     unzip apache-sis-0.5-src.zip
>     cd sis-0.5
>     patch -p0 < ../GML_version.patch
>     mvn install
>
>
>> For 3.1 / 3.1.1, i get a JAXBException.
>
> Can you post the stack trace? Even if "3.1" is not the desired value 
> here, I would like to see if it is easily fixable.
>
>     Martin
>
>


Mime
View raw message