sis-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Martin Desruisseaux (JIRA)" <j...@apache.org>
Subject [jira] [Created] (SIS-63) Fix <prerequisites> in sis-build-helper after Apache upgrated the Maven used by Jenkins
Date Mon, 24 Sep 2012 14:02:08 GMT
Martin Desruisseaux created SIS-63:
--------------------------------------

             Summary: Fix <prerequisites> in sis-build-helper after Apache upgrated
the Maven used by Jenkins
                 Key: SIS-63
                 URL: https://issues.apache.org/jira/browse/SIS-63
             Project: Spatial Information Systems
          Issue Type: Task
          Components: Build process
            Reporter: Martin Desruisseaux
            Priority: Trivial


The {{pom.xml}} file of the {{sis-build-helper}} module uses the {{$\{maven.version\}}} property,
which has been introduced only in Maven 3.0.4 ([MNG-4112|http://jira.codehaus.org/browse/MNG-4112]).
Consequently we should put the following section in the {{pom.xml}} file:

{code:xml}
<prerequisites>
  <maven>3.0.4</maven>
</prerequisites>
{code}

However at the time of writing this issue, we can not because Apache Jenkins is still using
Maven 3.0.3. We had to relax the prerequisite, but users need to be aware that they must declare
explicitly their Maven version if (and only if) older than 3.0.4, using the {{-D}} option
like below:

{noformat}
--define maven.version=3.0.3
{noformat}

We should declare the correct prerequisite, namely 3.0.4, when Jenkins will accept it. This
would allow users of older Maven versions who did not declared the above-cited property to
get a proper error message rather than a message about undefined property.


--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message