singa-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From GitBox <...@apache.org>
Subject [GitHub] [singa] dcslin commented on pull request #786: Fix a bug in github workflow (Native-MacOS) when using dnnl
Date Fri, 04 Sep 2020 13:20:50 GMT

dcslin commented on pull request #786:
URL: https://github.com/apache/singa/pull/786#issuecomment-687140995


   - I tried `dnnl_mac_1.1.0_cpu_tbb`. Installed tbb by `brew install tbb`, But the problem
persists, it could not load `libdnnl.1.dylib`
   - I also tried to use `dnnl_mac_1.1.0_cpu_iomp`, and installed dependency by `brew install
libomp`. After a few tweaks like ignoring security check on external library error from macos.
Still could not load the `libdnnl.1.dylib`
   - Using our dnnl conda package seems working fine, commands to reproduce:
     - `conda install -c nusdbsystem dnnl`
     - `export DNNL_ROOT=path/to/conda`
     - compile singa and run test and looks ok
   
   ```
   [09:19 pm] dcslin0:build sc$ ./bin/test_singa | head -n 10
   Running main() from gtest_main.cc
   [==========] Running 170 tests from 38 test cases.
   [----------] Global test environment set-up.
   [----------] 1 test from Accuracy
   [ RUN      ] Accuracy.Compute
   [       OK ] Accuracy.Compute (0 ms)
   [----------] 1 test from Accuracy (0 ms total)
   
   [----------] 3 tests from Activation
   [ RUN      ] Activation.Setup
   ```
   
   ```
   [09:17 pm] dcslin0:singa sc$ PYTHONPATH=build/python/ python3 -c "from singa import tensor"
   [09:20 pm] dcslin0:singa sc$ 
   ```


----------------------------------------------------------------
This is an automated message from the Apache Git Service.
To respond to the message, please log on to GitHub and use the
URL above to go to the specific comment.

For queries about this service, please contact Infrastructure at:
users@infra.apache.org



Mime
View raw message