singa-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From GitBox <...@apache.org>
Subject [GitHub] [singa] chrishkchris commented on pull request #709: Upgrade CUDNN version from 7.3.1 to 7.6.5
Date Thu, 28 May 2020 09:02:38 GMT

chrishkchris commented on pull request #709:
URL: https://github.com/apache/singa/pull/709#issuecomment-635215622


   Concerning my conda build test in our server:
   
   Firstly, the cuda runtime library version at each node is:
   panda 1-4 cuda 9.0
   panda 5-8 cuda 10.0 
   panda 5-16 cuda 10.1
   panda 17-18 cuda 10.2
   
   1. When I use the nvidia docker nvidia/cuda:10.0-devel-ubuntu16.04 to build the conda package
on panda 18 using cudatoolkit 10.2 and cudnn 7.6.5. It can build the package and pass the
test case. However, when I install the conda package and run, it returns error message: 
   "ImportError: libcudart.so.10.0: cannot open shared object file: No such file or directory"
   
   2. When I use the nvidia docker nvidia/cuda:10.2-devel-ubuntu16.04 to build conda package
on panda 18 using cudatoolkit 10.2 and cudnn 7.6.5. It can not compile with the error message:
   "/root/miniconda/conda-bld/singa_1590645399908/work/include/singa/utils/cuda_utils.h:24:23:
fatal error: cublas_v2.h: No such file or directory"
   
   3. Last time I built the conda package using cuda 10.0 cudnn 7.6.5, the package can be
used sucessfully at panda 7 and panda 13 (seems that runtime cuda library installed at every
nodes are backward compatiable)


----------------------------------------------------------------
This is an automated message from the Apache Git Service.
To respond to the message, please log on to GitHub and use the
URL above to go to the specific comment.

For queries about this service, please contact Infrastructure at:
users@infra.apache.org



Mime
View raw message