singa-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From GitBox <...@apache.org>
Subject [GitHub] [singa] agnesnatasya commented on issue #695: PackageNotFoundError in Installation
Date Thu, 14 May 2020 17:59:32 GMT

agnesnatasya commented on issue #695:
URL: https://github.com/apache/singa/issues/695#issuecomment-628795899


   Hi @dcslin thank you so much for replying to my issue. Yes, I did not create the virtual
environment properly. Now, I have created the virtual environment using 
   `conda create -n singa python=3.6`
   and I entered this command afterwards
   `conda install -c nusdbsystem -c conda-forge singa=3.0.0`
   
   I do not use singa-gpu=3.0.0 like you because if gave me a PackageNotFoundError as it is
not listed in my channel, singa=3.0.0 works for me though. 
   
   However, it still gave me a compatibility error. 
   ```
   UnsatisfiableError: The following specifications were found to be incompatible with each
other:
   
   
   
   Package libcxx conflicts for:
   python=3.6 -> libcxx[version='>=4.0.1']
   singa=3.0.0 -> libcxx[version='>=9.0.1']
   Package libopenblas conflicts for:
   singa=3.0.0 -> libopenblas=0.3.9
   Package numpy conflicts for:
   singa=3.0.0 -> numpy[version='>=1.16,<1.17.0a0']
   Package tk conflicts for:
   python=3.6 -> tk[version='8.6.*|>=8.6.7,<8.7.0a0|>=8.6.8,<8.7.0a0']
   Package zlib conflicts for:
   python=3.6 -> zlib[version='>=1.2.11,<1.3.0a0']
   Package glog conflicts for:
   singa=3.0.0 -> glog[version='>=0.3.5,<0.4.0a0']
   Package libprotobuf conflicts for:
   singa=3.0.0 -> libprotobuf=3.10.0
   Package python_abi conflicts for:
   singa=3.0.0 -> python_abi[version='3.6.*|3.7.*',build='*_cp37m|*_cp36m']
   Package tqdm conflicts for:
   singa=3.0.0 -> tqdm
   Package pip conflicts for:
   python=3.6 -> pip
   Package deprecated conflicts for:
   singa=3.0.0 -> deprecated=1.2.7
   Package sqlite conflicts for:
   python=3.6 -> sqlite[version='>=3.20.1,<4.0a0|>=3.22.0,<4.0a0|>=3.23.1,<4.0a0|>=3.24.0,<4.0a0|>=3.25.2,<4.0a0|>=3.26.0,<4.0a0|>=3.29.0,<4.0a0|>=3.30.1,<4.0a0|>=3.31.1,<4.0a0']
   Package xz conflicts for:
   python=3.6 -> xz[version='>=5.2.3,<6.0a0|>=5.2.4,<6.0a0|>=5.2.5,<6.0a0']
   Package readline conflicts for:
   python=3.6 -> readline[version='7.*|>=7.0,<8.0a0|>=8.0,<9.0a0']
   Package libffi conflicts for:
   python=3.6 -> libffi[version='3.2.*|>=3.2.1,<3.3a0|>=3.3,<3.4.0a0']
   Package future conflicts for:
   singa=3.0.0 -> future
   Package ncurses conflicts for:
   python=3.6 -> ncurses[version='>=6.0,<7.0a0|>=6.1,<7.0a0|>=6.2,<7.0a0']
   Package onnx conflicts for:
   singa=3.0.0 -> onnx=1.6.0
   Package dnnl conflicts for:
   singa=3.0.0 -> dnnl[version='>=1.1,<1.2.0a0']
   Package openssl conflicts for:
   python=3.6 -> openssl[version='1.0.*|1.0.*,>=1.0.2l,<1.0.3a|>=1.0.2m,<1.0.3a|>=1.0.2n,<1.0.3a|>=1.0.2o,<1.0.3a|>=1.1.1a,<1.1.2a|>=1.1.1c,<1.1.2a|>=1.1.1d,<1.1.2a|>=1.1.1e,<1.1.2a|>=1.1.1g,<1.1.2a']
   Package pillow conflicts for:
   singa=3.0.0 -> pillow
   ```
   I received similar long error message when I configure the python version of the virtual
environment to be 3.7. 
   
   Thus, I tried to create the virtual environment using package version according to what
singa wants, such as 
   ```
   conda install -n singa python=3.6 libcxx=9.0.1 libopenblas=0.3.9 numpy=1.16 tk=8.6.7 zlib=1.2.11
glog=0.3.5 tqdm pip deprecated=1.2.7 sqlite=3.20.1 xz=5.2.3 readline=7.0 libffi=3.2.1 future
ncurses=6.1 openssl=1.0.2 pillow
   ```
   
   It then give me some other incompatibility error like this
   ```
   UnsatisfiableError: The following specifications were found to be incompatible with a past
   explicit spec that is not an explicit spec in this operation (libopenblas):
   
     - libopenblas=0.3.9
     - numpy=1.16 -> mkl_random[version='>=1.0.2,<2.0a0'] -> numpy-base[version='>=1.0.2,<2.0a0,>=1.0.4,<2.0a0']
-> libopenblas[version='>=0.3.3,<1.0a0']
   
   The following specifications were found to be incompatible with each other:
   
   
   
   Package libgfortran conflicts for:
   libgfortran
   numpy=1.16 -> mkl_random[version='>=1.0.2,<2.0a0'] -> numpy-base[version='>=1.0.2,<2.0a0,>=1.0.4,<2.0a0']
-> libopenblas[version='>=0.3.3,<1.0a0'] -> libgfortran[version='>=3.0.1,<4.0.0.a0']
   libopenblas=0.3.9 -> libgfortran[version='>=4.0.0,<5.0.0.a0']
   ```
   
   Really apologise for the trouble, do you have any idea why this is happening?
   


----------------------------------------------------------------
This is an automated message from the Apache Git Service.
To respond to the message, please log on to GitHub and use the
URL above to go to the specific comment.

For queries about this service, please contact Infrastructure at:
users@infra.apache.org



Mime
View raw message