singa-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Shreyansh Shrivastava (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (SINGA-470) SINGA 1.2.0 to 2.0.0 upgrade error
Date Fri, 19 Jul 2019 11:42:00 GMT

    [ https://issues.apache.org/jira/browse/SINGA-470?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16888807#comment-16888807
] 

Shreyansh Shrivastava commented on SINGA-470:
---------------------------------------------

I ran the conda command. Importing tensor from singa gives "*TypeError: __init__() got an
unexpected keyword argument 'serialized_options'*".

*ldd _singa_wrap.so*
linux-vdso.so.1 =>  (0x00007ffd6cf88000)
	libprotobuf.so.17 => /home/shreyansh/miniconda3/envs/singa/lib/python3.6/site-packages/singa/./../../../libprotobuf.so.17
(0x00007fe2c20f1000)
	libopenblas.so.0 => /home/shreyansh/miniconda3/envs/singa/lib/python3.6/site-packages/singa/./../../../libopenblas.so.0
(0x00007fe2c04cd000)
	libglog.so.0 => /home/shreyansh/miniconda3/envs/singa/lib/python3.6/site-packages/singa/./../../../libglog.so.0
(0x00007fe2c2ac3000)
	libmkldnn.so.0 => /home/shreyansh/miniconda3/envs/singa/lib/python3.6/site-packages/singa/./../../../libmkldnn.so.0
(0x00007fe2bfd92000)
	libpython3.6m.so.1.0 => /home/shreyansh/miniconda3/envs/singa/lib/python3.6/site-packages/singa/./../../../libpython3.6m.so.1.0
(0x00007fe2bfa4b000)
	libstdc++.so.6 => /home/shreyansh/miniconda3/envs/singa/lib/python3.6/site-packages/singa/./../../../libstdc++.so.6
(0x00007fe2bf68f000)
	libm.so.6 => /lib64/libm.so.6 (0x00007fe2bf38d000)
	libgcc_s.so.1 => /home/shreyansh/miniconda3/envs/singa/lib/python3.6/site-packages/singa/./../../../libgcc_s.so.1
(0x00007fe2bf176000)
	libpthread.so.0 => /lib64/libpthread.so.0 (0x00007fe2bef5a000)
	libc.so.6 => /lib64/libc.so.6 (0x00007fe2beb8d000)
	/lib64/ld-linux-x86-64.so.2 (0x00007fe2c28d8000)
	libz.so.1 => /home/shreyansh/miniconda3/envs/singa/lib/python3.6/site-packages/singa/./../../.././libz.so.1
(0x00007fe2c2a89000)
	libgfortran.so.4 => /home/shreyansh/miniconda3/envs/singa/lib/python3.6/site-packages/singa/./../../.././libgfortran.so.4
(0x00007fe2c295b000)
	libmklml_intel.so => /home/shreyansh/miniconda3/envs/singa/lib/python3.6/site-packages/singa/./../../.././libmklml_intel.so
(0x00007fe2b5a56000)
	libiomp5.so => /home/shreyansh/miniconda3/envs/singa/lib/python3.6/site-packages/singa/./../../.././libiomp5.so
(0x00007fe2b567b000)
	libdl.so.2 => /lib64/libdl.so.2 (0x00007fe2b5477000)
	libutil.so.1 => /lib64/libutil.so.1 (0x00007fe2b5274000)
	librt.so.1 => /lib64/librt.so.1 (0x00007fe2b506c000)
	libquadmath.so.0 => /home/shreyansh/miniconda3/envs/singa/lib/python3.6/site-packages/singa/./../../.././libquadmath.so.0
(0x00007fe2b4e2d000)


> SINGA 1.2.0 to 2.0.0 upgrade error
> ----------------------------------
>
>                 Key: SINGA-470
>                 URL: https://issues.apache.org/jira/browse/SINGA-470
>             Project: Singa
>          Issue Type: Bug
>          Components: Application
>         Environment: CentOS7
> miniconda 3
>            Reporter: Shreyansh Shrivastava
>            Priority: Major
>         Attachments: ldd _singa_wrap.so.png
>
>
> "*conda install -c nusdbsystem -c conda-forge singa-cpu*" updated the SINGA package *from
1.2.0 to 2.0.0* but is throwing error on importing any module from singa on jupyter notebook.
> *Error*
> *ImportError:* libprotobuf.so.14: cannot open shared object file: No such file or directory
> *ModuleNotFoundError:* No module named '_singa_wrap'
> ldd _singa_wrap.so outputs *libprotobuf.so.14 => not found*



--
This message was sent by Atlassian JIRA
(v7.6.14#76016)

Mime
View raw message