singa-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "wangwei (JIRA)" <j...@apache.org>
Subject [jira] [Created] (SINGA-432) Update depdent lib versions in conda-build config
Date Fri, 15 Mar 2019 14:41:00 GMT
wangwei created SINGA-432:
-----------------------------

             Summary: Update depdent lib versions in conda-build config
                 Key: SINGA-432
                 URL: https://issues.apache.org/jira/browse/SINGA-432
             Project: Singa
          Issue Type: Improvement
            Reporter: wangwei


We have been using gcc 4.8.5 to Singa.

The latest gcc is 8.2. Many dependent libs (e.g., protobuf) are built with newer versions
of gcc which has a different ABI as 4.8.5.

This ticket is going to update these libs and gcc using [conda-build 3.0|[https://www.anaconda.com/package-better-conda-build-3/].]
 # introduce the build, host and run sections in meta.yaml
 # introduce the conda_build_config.yaml to configure the lib versions. note the gcc version [must
be 5.4|https://docs.conda.io/projects/conda-build/en/latest/resources/variants.html] as cuda
does not support gcc>=6.
 # use the compiler selected by conda via c_complier() cxx_compiler()
 # use the cudnn from anaconda.
 # move docker for conda build into tool/conda. Now the dockerfile for conda build and the
dockerfile for devel are different. The former one uses the libs from anaconda. The later
one uses the latest libs from ubuntu.

 



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message