singa-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ngin Yun Chuan (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (SINGA-401) Rafiki - sudo requirement during installation
Date Fri, 09 Nov 2018 00:04:00 GMT

    [ https://issues.apache.org/jira/browse/SINGA-401?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16680633#comment-16680633
] 

Ngin Yun Chuan commented on SINGA-401:
--------------------------------------

Thanks for the report! We've just pushed some code - try the latest commit.

Currently, Rafiki's logs folder is at `/var/log/rafiki` and the setup script is trying to
create that folder. The updated instructions at https://nginyc.github.io/rafiki/docs/docs/dev/setup-development.html
specify  the use of `sudo` in the main command. Without `sudo`, it might not have the permission
to do so e.g. on my Mac Mojave.


> Rafiki - sudo requirement during installation
> ---------------------------------------------
>
>                 Key: SINGA-401
>                 URL: https://issues.apache.org/jira/browse/SINGA-401
>             Project: Singa
>          Issue Type: Bug
>            Reporter: Ng Yi Sen
>            Priority: Major
>         Attachments: rafiki_sudo_error.jpg, rafiki_sudo_error_2.jpg
>
>
> Hi,
>  
> After the latest commits, whenever I tried to install Rafiki, the sudo password prompt
will appear. I believe this has never happened before the recent 0.0.5 update. When I tried
to bypass this restriction using ctrl-c or entering erroneous password consecutively, the
installation can continue but doesn't automatically create the logs folder.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message