singa-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ngin Yun Chuan (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (SINGA-397) Deployment Issues for Rafiki
Date Mon, 22 Oct 2018 03:32:00 GMT

    [ https://issues.apache.org/jira/browse/SINGA-397?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16658514#comment-16658514
] 

Ngin Yun Chuan commented on SINGA-397:
--------------------------------------

Hi Junyou,

It is possible that in scenario `1.png`, the train job is still running, so it appears as
the system halted. I edit `client-usage.py` to emit more feedback at this stage.

For `2.png`, it seems like you have not started a train job nor added any models before you
tried to start an inference job. What were exact sequence of commands you ran after system
setup? I will add better error messages to notify users in this case.

Check the sequence of commands in `client-usage.py` for the full train-inference flow. Model
developers have to add models for a specific task first, then app developers can start a train
job, and only after the train job has completed, an inference job associated to that train
job can be started. Let me know which parts are more confusing, so that I can add better documentation
for those parts.


> Deployment Issues for Rafiki
> ----------------------------
>
>                 Key: SINGA-397
>                 URL: https://issues.apache.org/jira/browse/SINGA-397
>             Project: Singa
>          Issue Type: Test
>         Environment: ubuntu 18, local machine
>            Reporter: Junyou Chen
>            Priority: Major
>         Attachments: 1.png, 2.png
>
>
> After I deployed Rafiki on my own machine by following the Quick Setup section in the
Developer Guide, I tried to run the $client-usage.py$ but failed(as picture 1 shows. system
halted with no feedback). Also, I followed several examples in the User Guide, but there are
still some problems(shown in picture 2).



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message