singa-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ASF subversion and git services (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (SINGA-290) Upgrade to Python 3
Date Tue, 15 Aug 2017 15:18:00 GMT

    [ https://issues.apache.org/jira/browse/SINGA-290?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16127363#comment-16127363
] 

ASF subversion and git services commented on SINGA-290:
-------------------------------------------------------

Commit 8d03bd8d0373962cb1da5aee5aa96165f6d46e6b in incubator-singa's branch refs/heads/master
from [~flytosky]
[ https://git-wip-us.apache.org/repos/asf?p=incubator-singa.git;h=8d03bd8 ]

SINGA-290 Upgrade to Python 3

Fix the bugs for kernel/pad setting for 1D conv/pool
Fix the bugs for python unit test (uneven padding for testing conv layers)


> Upgrade to Python 3
> -------------------
>
>                 Key: SINGA-290
>                 URL: https://issues.apache.org/jira/browse/SINGA-290
>             Project: Singa
>          Issue Type: Improvement
>            Reporter: Moaz Reyad
>
> Currently SINGA supports Python 2.7, we need to upgrade to Python 3.
> One reason for this upgrade is related to SINGA-274, where new Debian packages are required
to use Python 3 according to Debian packaging policy on Python:
> https://www.debian.org/doc/packaging-manuals/python-policy/ch-python3.html



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message