singa-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "wangwei (JIRA)" <j...@apache.org>
Subject [jira] [Resolved] (SINGA-255) Compile mandatory depedent libaries together with SINGA code
Date Wed, 16 Nov 2016 04:29:58 GMT

     [ https://issues.apache.org/jira/browse/SINGA-255?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

wangwei resolved SINGA-255.
---------------------------
    Resolution: Fixed

> Compile mandatory depedent libaries together with SINGA code
> ------------------------------------------------------------
>
>                 Key: SINGA-255
>                 URL: https://issues.apache.org/jira/browse/SINGA-255
>             Project: Singa
>          Issue Type: Improvement
>            Reporter: wangwei
>            Assignee: Xie Zhongle
>
> Sometimes, users would install the dependent libraries from mismatched versions or misconfigure
the environment paths for the dependent libraries.
> To avoid the installation error (e.g. http://stackoverflow.com/questions/39477252/failed-to-run-apache-singa-after-installation)
this step, we can update our cmake file to add one option for  compiling the mandatory libraries
together with SINGA. Currently, the mandatory dependent libraries are openblas and protobuf.
Both can be compiled using cmake. (cmake has been added into protobuf since v2.7).



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message