shiro-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jared Bunting <jared.bunt...@peachjean.com>
Subject Re: Apache Shiro First Use in NetBeans
Date Sat, 26 Jul 2014 23:34:16 GMT
Can you share your error?
On Jul 26, 2014 4:22 PM, "KonradZuse" <TheKonradzuse@hotmail.com> wrote:

> I knoe this is old, but I am getting the same issues.
>
> I tried your example, but it doesn't work either.
>
> I was having issues getting my project to work, I was getting "tag issues"
> but then I realized my web.xml isn't correct, so I tried adding the needed
> stuff but now it gives me the same error.  This is my web.xml
> <?xml version="1.0" encoding="UTF-8"?>
> <web-app version="3.1" xmlns="http://xmlns.jcp.org/xml/ns/javaee"
> xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
> xsi:schemaLocation="http://xmlns.jcp.org/xml/ns/javaee
> http://xmlns.jcp.org/xml/ns/javaee/web-app_3_1.xsd">
>
>
>      <listener>
>
>
> <listener-class>org.apache.shiro.web.env.EnvironmentLoaderListener</listener-class>
>     </listener>
>
>     <filter>
>         <filter-name>ShiroFilter</filter-name>
>
> <filter-class>org.apache.shiro.web.servlet.ShiroFilter</filter-class>
>     </filter>
>
>     <filter-mapping>
>         <filter-name>ShiroFilter</filter-name>
>         <url-pattern>/*</url-pattern>
>         <dispatcher>REQUEST</dispatcher>
>         <dispatcher>FORWARD</dispatcher>
>         <dispatcher>INCLUDE</dispatcher>
>         <dispatcher>ERROR</dispatcher>
>     </filter-mapping>
>
>     <welcome-file-list>
>         <welcome-file>index.jsp</welcome-file>
>     </welcome-file-list>
>
>     <servlet>
>         <servlet-name>viewerServlet</servlet-name>
>         <servlet-class>viewerServlet</servlet-class>
>     </servlet>
>     <servlet-mapping>
>         <servlet-name>viewerServlet</servlet-name>
>         <url-pattern>/viewerServlet</url-pattern>
>     </servlet-mapping>
>     <session-config>
>         <session-timeout>
>             30
>         </session-timeout>
>     </session-config>
>
> </web-app>
>
>
> I have tried moving the thing around inside seeing if that might have
> bugged
> it out, but nothing.  Everything is inside the web-app tags.
>
> The issue happens when I call
>      <listener>
>
>
> <listener-class>org.apache.shiro.web.env.EnvironmentLoaderListener</listener-class>
>     </listener>
>
>     <filter>
>         <filter-name>ShiroFilter</filter-name>
>
> <filter-class>org.apache.shiro.web.servlet.ShiroFilter</filter-class>
>     </filter>
>
>     <filter-mapping>
>         <filter-name>ShiroFilter</filter-name>
>         <url-pattern>/*</url-pattern>
>         <dispatcher>REQUEST</dispatcher>
>         <dispatcher>FORWARD</dispatcher>
>         <dispatcher>INCLUDE</dispatcher>
>         <dispatcher>ERROR</dispatcher>
>     </filter-mapping>
>
>     <welcome-file-list>
>         <welcome-file>index.jsp</welcome-file>
>     </welcome-file-list>
>
> I have a working example that I cloned from the shiro site, but I cannot
> get
> it working in my own project... ugh..
>
> Thanks for any help!
>
>
>
> --
> View this message in context:
> http://shiro-user.582556.n2.nabble.com/Apache-Shiro-First-Use-in-NetBeans-tp7578762p7580100.html
> Sent from the Shiro User mailing list archive at Nabble.com.
>

Mime
View raw message