shiro-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Brian Demers (JIRA)" <j...@apache.org>
Subject [jira] [Closed] (SHIRO-513) Misleading error message when using custom WebEnvironment
Date Mon, 21 Nov 2016 14:47:58 GMT

     [ https://issues.apache.org/jira/browse/SHIRO-513?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Brian Demers closed SHIRO-513.
------------------------------

> Misleading error message when using custom WebEnvironment
> ---------------------------------------------------------
>
>                 Key: SHIRO-513
>                 URL: https://issues.apache.org/jira/browse/SHIRO-513
>             Project: Shiro
>          Issue Type: Bug
>          Components: Web
>    Affects Versions: 1.2.3
>            Reporter: Andreas Kohn
>            Priority: Trivial
>             Fix For: 1.3.0
>
>
> Found while reading the code in EnvironmentLoader#createEnvironment():
> {code}
>         Class<?> clazz = determineWebEnvironmentClass(sc);
>         if (!MutableWebEnvironment.class.isAssignableFrom(clazz)) {
>             throw new ConfigurationException("Custom WebEnvironment class [" + clazz.getName()
+
>                     "] is not of required type [" + WebEnvironment.class.getName() +
"]");
>         }
> {code}
> The message says you need a WebEnvironment, the check (and later code) however requires
_Mutable_WebEnvironment.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message