shiro-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Brian Demers (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (SHIRO-359) Realm not initialised when bound in servlet mode with guice
Date Fri, 24 Jun 2016 00:12:16 GMT

    [ https://issues.apache.org/jira/browse/SHIRO-359?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15347463#comment-15347463
] 

Brian Demers commented on SHIRO-359:
------------------------------------

Added "patch" label based on the previous comment


> Realm not initialised when bound in servlet mode with guice
> -----------------------------------------------------------
>
>                 Key: SHIRO-359
>                 URL: https://issues.apache.org/jira/browse/SHIRO-359
>             Project: Shiro
>          Issue Type: Bug
>          Components: Realms 
>    Affects Versions: 1.2.0
>            Reporter: HG
>            Assignee: Jared Bunting
>              Labels: OnInit, patch
>         Attachments: OxAuthenticatingRealm.java, ShiroConfigurationModule.java
>
>
> I have a SampleRealm class which extends TextConfigurationRealm. 
> I bind it in configureShiroWeb() method of ShiroWebModule with   bindRealm().to(SampleRealm
.class).in(Singleton.class);
> My expectation is OnInit() to be called at some point.
> But that never happens. 
> I guess that should happen through  InitializableInjectionListener() with Guice, but
doesn't get triggered.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message