shiro-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Brian Demers (JIRA)" <j...@apache.org>
Subject [jira] [Resolved] (SHIRO-556) https://shiro.apache.org/realm.html appears to link to the javadoc under static/current/apidocs not static/latest
Date Sat, 05 Mar 2016 00:10:40 GMT

     [ https://issues.apache.org/jira/browse/SHIRO-556?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Brian Demers resolved SHIRO-556.
--------------------------------
       Resolution: Fixed
    Fix Version/s: 1.2.4

redeployed site and updated current/latest symlinks

>  https://shiro.apache.org/realm.html appears to link to the javadoc under static/current/apidocs
not static/latest
> ------------------------------------------------------------------------------------------------------------------
>
>                 Key: SHIRO-556
>                 URL: https://issues.apache.org/jira/browse/SHIRO-556
>             Project: Shiro
>          Issue Type: Bug
>          Components: Documentation
>            Reporter: Daniel Takamori
>              Labels: documentation
>             Fix For: 1.2.4
>
>
> Tom Hayhurst (tom@catena-technologies.com) e-mailed the infrastructure@apache.org initially
with:
> "https://shiro.apache.org/static/current/apidocs/org/apache/shiro/realm/Realm.html gives
me an HTTP 500 response."
> This lead to the exchange:
> "> On 13 Jan 2016, at 11:20 pm, Daniel Takamori <pono@apache.org> wrote:
> >
> > Hey Tom,
> > While poking around, I noticed that https://shiro.apache.org/static/latest/apidocs/org/apache/shiro/realm/Realm.html
would load but your link wouldn't.  Is https://shiro.apache.org/static/current/ supposed to
be where things are located?  If so where was that link followed from?
> Sorry - I should have explained. All of the non-Javadoc Shiro documentation (e.g. https://shiro.apache.org/realm.html)
appears to link to the javadoc under static/current/apidocs not static/latest. I suppose the
fact that I got a 500 not a 404 made me think that there was a problem with the server rather
than the incoming link being wrong.
> Thanks for the info!"
> Handing off to the Shiro team.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message