shiro-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Dan Dumont (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (SHIRO-549) pom specified incorrect package versions for guice
Date Sun, 08 Nov 2015 01:22:10 GMT

     [ https://issues.apache.org/jira/browse/SHIRO-549?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Dan Dumont updated SHIRO-549:
-----------------------------
    Attachment: shiro.patch

> pom specified incorrect package versions for guice
> --------------------------------------------------
>
>                 Key: SHIRO-549
>                 URL: https://issues.apache.org/jira/browse/SHIRO-549
>             Project: Shiro
>          Issue Type: Bug
>          Components: Integration: Guice
>    Affects Versions: 1.2.0, 1.2.1, 1.2.2, 1.2.3, 2.0.0, 1.2.4
>            Reporter: Dan Dumont
>            Assignee: Jared Bunting
>              Labels: build, easyfix, maven, patch
>         Attachments: shiro.patch
>
>
> The maven bundle plugin will auto fill the package versions of the referenced packages.
 So I removed the version specified and verified with a build that the correct 1.3 (can you
please consider upgrading to Guice 4.0 (1.4)) version appears in the bundle manifest.
> I would love if you could push out a quick 1.2.5 with this change.  My OSGi deployments
are currently blocked by this.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message