shiro-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Les Hazlewood (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (SHIRO-359) Realm not initialised when bound in servlet mode with guice
Date Wed, 17 Apr 2013 04:45:15 GMT

    [ https://issues.apache.org/jira/browse/SHIRO-359?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13633780#comment-13633780
] 

Les Hazlewood commented on SHIRO-359:
-------------------------------------

Hi Jared,

Any update on this?  I'd like to see if we can get Shiro 1.2.2 out sometime soon.  Thoughts?
                
> Realm not initialised when bound in servlet mode with guice
> -----------------------------------------------------------
>
>                 Key: SHIRO-359
>                 URL: https://issues.apache.org/jira/browse/SHIRO-359
>             Project: Shiro
>          Issue Type: Bug
>          Components: Realms 
>    Affects Versions: 1.2.0
>            Reporter: HG
>            Assignee: Jared Bunting
>              Labels: OnInit
>         Attachments: OxAuthenticatingRealm.java, ShiroConfigurationModule.java
>
>
> I have a SampleRealm class which extends TextConfigurationRealm. 
> I bind it in configureShiroWeb() method of ShiroWebModule with   bindRealm().to(SampleRealm
.class).in(Singleton.class);
> My expectation is OnInit() to be called at some point.
> But that never happens. 
> I guess that should happen through  InitializableInjectionListener() with Guice, but
doesn't get triggered.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message