shiro-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Bogdan Flueras (JIRA)" <j...@apache.org>
Subject [jira] [Created] (SHIRO-398) Inconsistent name for session validation interval property in different implementations
Date Fri, 23 Nov 2012 11:34:58 GMT
Bogdan Flueras created SHIRO-398:
------------------------------------

             Summary: Inconsistent name for session validation interval property in different
implementations
                 Key: SHIRO-398
                 URL: https://issues.apache.org/jira/browse/SHIRO-398
             Project: Shiro
          Issue Type: Bug
    Affects Versions: 1.2.1
            Reporter: Bogdan Flueras
            Priority: Minor


In the subclasses of SessionValidationScheduler the session validation interval name is inconsistent:
In ExecutorServiceSessionValidationScheduler is "interval" 
whereas in QuartzSessionValidationScheduler is "sessionValidationInterval".
The problem would be when switching implementations of the SessionValidationScheduler in the
shiro.ini config file, and renaming this property too.



--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message