shiro-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Les Hazlewood (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (SHIRO-359) Realm not initialised when bound in servlet mode with guice
Date Tue, 24 Jul 2012 21:41:35 GMT

    [ https://issues.apache.org/jira/browse/SHIRO-359?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13421790#comment-13421790
] 

Les Hazlewood commented on SHIRO-359:
-------------------------------------

Jared, I just assigned this to you as I assume you're the man for the job.  If not, please
unassign.
                
> Realm not initialised when bound in servlet mode with guice
> -----------------------------------------------------------
>
>                 Key: SHIRO-359
>                 URL: https://issues.apache.org/jira/browse/SHIRO-359
>             Project: Shiro
>          Issue Type: Bug
>          Components: Realms 
>    Affects Versions: 1.2.0
>            Reporter: HG
>            Assignee: Jared Bunting
>              Labels: OnInit
>         Attachments: OxAuthenticatingRealm.java, ShiroConfigurationModule.java
>
>
> I have a SampleRealm class which extends TextConfigurationRealm. 
> I bind it in configureShiroWeb() method of ShiroWebModule with   bindRealm().to(SampleRealm
.class).in(Singleton.class);
> My expectation is OnInit() to be called at some point.
> But that never happens. 
> I guess that should happen through  InitializableInjectionListener() with Guice, but
doesn't get triggered.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message