shiro-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Les Hazlewood (JIRA)" <j...@apache.org>
Subject [jira] Commented: (SHIRO-208) Correct JDK 1.5 / 1.6 incompatibilities
Date Sat, 30 Oct 2010 19:01:19 GMT

    [ https://issues.apache.org/jira/browse/SHIRO-208?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12926629#action_12926629
] 

Les Hazlewood commented on SHIRO-208:
-------------------------------------

I thought it was, based on this in the shiro-root POM (where ${jdk.version} is indeed '1.5'):

<plugins>
...
<plugin>
    <groupId>org.apache.maven.plugins</groupId>
    <artifactId>maven-compiler-plugin</artifactId>
    <version>2.0.2</version>
    <configuration>
        <source>${jdk.version}</source>
        <target>${jdk.version}</target>
        <encoding>${project.build.sourceEncoding}</encoding>
    </configuration>
</plugin>
...
</plugins>

Any ideas what we might be missing?

> Correct JDK 1.5 / 1.6 incompatibilities
> ---------------------------------------
>
>                 Key: SHIRO-208
>                 URL: https://issues.apache.org/jira/browse/SHIRO-208
>             Project: Shiro
>          Issue Type: Task
>    Affects Versions: 1.0.0
>            Reporter: Les Hazlewood
>             Fix For: 1.1.1
>
>
> The current trunk is not JDK 1.5 compatible.  Fix these incompatibilities until the dev
team decides such a time that we wish to be only 1.6+ compliant.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message