shiro-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Les Hazlewood <lhazlew...@apache.org>
Subject Re: Ini config: Rename [main] section to [beans] ?
Date Sun, 09 May 2010 03:19:58 GMT
Ah, interesting Erik - that could work too.  Thanks for the feedback!

If anyone else wants to offer feedback, please do so soon - I hope to
wrap this up as soon as possible to be code complete for 1.0 by Monday
at the latest.

Thanks,

Les

On Sat, May 8, 2010 at 8:02 PM, Erik Beeson <erik.beeson@gmail.com> wrote:
> I understand what you're saying, but "beans" doesn't seem very meaningful in
> the context of Shiro. I think "config" (which would be a bit redundant) or
> "setup" might make more sense. Or leave it "main" and have a new global
> options section be called "options" or "settings" or something?
>
> In the end, I don't think it matters much. We'll use whatever you do :)
>
> --Erik
>
>
> On Sat, May 8, 2010 at 10:44 PM, Les Hazlewood <lhazlewood@apache.org>wrote:
>
>> Hi Juan,
>>
>> I think you might have missed my point:
>>
>> The [main] section today IS the same thing as a Spring-style
>> configuration - it just uses INI instead of XML.  It configures
>> JavaBeans and builds object graphs and nothing else.  That's why I'd
>> like to change the name to [beans] - so the section name correctly
>> reflects the current behavior.
>>
>> I also wanted to change the name so that if we ever decided to bring
>> back the [main] section, it could be used for things other than
>> beans-style configuration.  You can't mix them both in the same
>> section.
>>
>> Does that make sense?
>>
>> Les
>>
>> On Sat, May 8, 2010 at 7:06 PM, Juan Chung <jiayanchung@gmail.com> wrote:
>> > [beans] is a more general name, it likes spring-style configuration. so
>> > it cannot clearly express this section's function in Shiro.
>> >
>> > but [main] is a more meaningful name for Shiro, it tells the end-user it
>> > lies in the Core of Shiro, without it Shiro will not be able to work.
>> >
>> > I think [main] is a better name than [beans] in Shiro.
>> >
>> > On 2010-5-9 7:27, Les Hazlewood wrote:
>> >>
>> >> The [main] section now exists for the sole purpose of java-beans-style
>> >> creation, configuration, and object graph assembly.
>> >>
>> >> Because of this, I'm thinking the [main] section should be renamed to
>> >> [beans] to indicate this.  The idea is that it is easily conceivable
>> >> that we'll need a [main] section at some time for framework-wide
>> >> directives that might not be able to be represented as a bean/property
>> >> configuration line.
>> >>
>> >> Thoughts?
>> >>
>> >> Les
>> >>
>> >
>> >
>>
>

Mime
View raw message