shindig-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jasha Joachimsthal <ja...@apache.org>
Subject Re: No love for Java 5?
Date Mon, 30 Jul 2012 06:08:20 GMT
The reference to the vote is missing.

Oracle ended the extended support for Java 5 a year ago and Java 6 is going
to become EOL later this year:
http://www.oracle.com/technetwork/java/eol-135779.html

I'd say drop Java 5 support for the final 2.5.0 release. If that's
unacceptable, drop it in 3.0.0 and make sure there will be a Java 5
compatible release of 2.5.0.

Jasha

On 30 July 2012 02:42, Ryan Baxter <rbaxter85@gmail.com> wrote:

> We had a vote about this a year ago [1] and it looks like at least one
> consumer said they needed Java 5 support.
>
> Mike, does Liferay still have the same requirements?
>
> On Sat, Jul 28, 2012 at 10:15 PM, Stanton Sievers <ssievers@apache.org
> >wrote:
>
> > Is anyone building or using Shindig in a Java 5 environment?  I've tried
> > building against Java 5 with the "java5" profile and I've hit a half
> dozen
> > compile issues already that have been around for a while.
> >
> > Are we planning on supporting Java 5 for 2.5.0?  I'd like to get the
> > consensus on the dev list and then send a vote out to the users lists if
> > necessary to get a feel for the desire to have Java 5 support.
> >
> > Thanks,
> > -Stanton
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message