shindig-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From John Hjelmstad <fa...@google.com>
Subject Re: trunk unstable...
Date Tue, 16 Mar 2010 21:01:42 GMT
Yeah... the additional parsing restrictions were a mistake. I've got one CL
(which you reviewed) pulling back the host verification stuff, and Ziv is
easing up the start/end beacon parsing thing as well.

--John

On Tue, Mar 16, 2010 at 1:29 PM, Paul Lindner <lindner@inuus.com> wrote:

> actually it was samplecontainer that was broken.  If you load any gadget
> with script tags you'll get failures (such as labpixies.. etal)
>
>
> On Tue, Mar 16, 2010 at 1:16 PM, John Hjelmstad <fargo@google.com> wrote:
>
> > On Tue, Mar 16, 2010 at 12:43 PM, Paul Lindner <plindner@linkedin.com
> > >wrote:
> >
> > > Hi,
> > >
> > > I've been digging back into the source and found a few things of note:
> > >
> > > DefaultConcatUri causes many gadgets to fail because it has a hardcoded
> > > hostname of localhost:9003 I'll probably reuse the %host% idiom to get
> > this
> > > to pass for the moment..
> > >
> >
> > %host% should work nicely for this, thanks Paul. Even so, I'm surprised
> > this
> > was causing problems. The trunk was clean for me... which test(s) errored
> > out?
> >
> >
> > >
> > > The end-to-end tests are ignoring their errors, probably since the
> junit4
> > > upgrade.  The osapi tests in there are using an older version of the
> api
> > > and
> > > are broken.  Two endtoend caja tests are failing with errors:
> > >
> > >  SEVERE: Job run failed with unexpected RuntimeException: Error:
> Already
> > > tames to something: [object Object]   (
> > >
> > >
> >
> http://localhost:9003/gadgets/js/caja.js?v=75fe169d11a71cf89a927e188571bf&amp;container=default&amp;debug=0#49
> > > )
> > > net.sourceforge.htmlunit.corejs.javascript.JavaScriptException: Error:
> > > Already tames to something: [object Object] (
> > >
> > >
> >
> http://localhost:9003/gadgets/js/caja.js?v=75fe169d11a71cf89a927e188571bf&amp;container=default&amp;debug=0#49
> > > )
> > >
> > >
> > > htmlunit is also complaining heavily about ampersands in URLs, which we
> > > should really fix -- and it appears that some of the javascript doesn't
> > run
> > > synchronously, breaking yet more tests...
> > >
> > > phew..
> > >
> > > I'll have some quick fixes today.
> > >
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message