shale-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Cyril Bouteille (JIRA)" <j...@apache.org>
Subject [jira] Created: (SHALE-498) Shale remoting call does not decode request parameter with utf-8 character properly
Date Sun, 22 Mar 2009 00:24:02 GMT
Shale remoting call does not decode request parameter with utf-8 character properly
-----------------------------------------------------------------------------------

                 Key: SHALE-498
                 URL: https://issues.apache.org/struts/browse/SHALE-498
             Project: Shale
          Issue Type: Bug
          Components: Remoting
    Affects Versions: 1.0.4
         Environment: Java 1.6.0_11 + Sun App Server 9.1_02p5 w/ Mojarra 1.2_04-b22-p05.
            Reporter: Cyril Bouteille


We seem to have a problem decoding HTTP params e.g. "Občanská Plovárna" gets decoded as
"Ob?anská Plovárna"
Note á gets decoded ok but not č although our <sun-web-app><parameter-encoding
default-charset="utf-8"/>
The decoding is fine with standard JSP/JSF if we don't go through Shale Remoting.
This looks very much like http://issues.apache.org/struts/browse/SHALE-282 but on the incoming/decoding
side.
I posted a note on the user mailing list but no response.
Can anyone confirm if there is a similar issue with Shale parameter decoding on the request/reader
side?
Thanks!

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message