shale-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Steven Decock (JIRA)" <j...@apache.org>
Subject [jira] Created: (SHALE-497) ValidatorTag.class referenced in shale-core TLD is missing. If shale-validator added DoubleValidatorTag.class missing. Deployment impossible on Weblogic 10.3!
Date Thu, 11 Dec 2008 12:11:37 GMT
ValidatorTag.class referenced in shale-core TLD is missing. If shale-validator added DoubleValidatorTag.class
missing. Deployment impossible on Weblogic 10.3!
--------------------------------------------------------------------------------------------------------------------------------------------------------------

                 Key: SHALE-497
                 URL: https://issues.apache.org/struts/browse/SHALE-497
             Project: Shale
          Issue Type: Bug
          Components: Core, Validator
    Affects Versions: 1.0.4, 1.0.5
         Environment: Weblogic 10.3
Bea JRockit 160_05
JSF 1.2 Mojarra RI
RichFaces 3.2.2.SR1
Maven 2.0.9


            Reporter: Steven Decock
            Priority: Blocker


On my first try with Shale I am already unable to deploy my webapp with the shale-core library
included in WEB-INF/lib.

This is the problem:
shale-core-1.0.4.jar (or shale-core-1.0.5.jar) contains a reference to org.apache.shale.validator.faces.ValidatorTag
in taglib.tld.

The problem is that this class is missing from the jar. Even though this tag is deprecated
this still remains a problem when deploying in WebLogic 10.3 (ClassNotFoundException).
Th class org.apache.shale.validator.faces.ValidatorTag is present in shale-validator-1.0.4.jar
however, but adding this jar just moves the problem to DoubleValidatorTag.class, which is
referenced in validators.tld in shale-validator-1.0.4.jar.
The DoubleValidatorTag.class is nowhere to be found.

The bottom line is that I cannot deploy at all with the shale-jars in my webapp because of
these missing classes.
I don't know if this is a Weblogic-only problem. It must be, if not I don't understand how
nobody else has run into this issue.

In my opinion the ValidatorTag reference in shale-core should be removed, because this creates
a dependency from shale-core to shale-validator, which is not wanted. 

Regarding the DoubleValidatorTag reference in shale-validator, these are the solutions (pick
one):
1. Remove the DoubleValidatorTag reference from validators.tld
2. Add DoubleValidatorTag.class to shale-validator-1.0.4.jar
3. Add a dependency in maven from shale-validator to whatever jar contains DoubleValidatorTag.class

For the time being I am forced to alter the taglib.tld file in shale-core-1.0.4.jar to be
able to deploy.



-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message