shale-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Gary VanMatre (JIRA)" <j...@apache.org>
Subject [jira] Commented: (SHALE-437) Setting Locale on ViewRoot to an EL Expression is broken
Date Wed, 18 Apr 2007 14:26:43 GMT

    [ https://issues.apache.org/struts/browse/SHALE-437?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#action_40838
] 

Gary VanMatre commented on SHALE-437:
-------------------------------------

Please verify that the backing value binding returns a Locale object.
Furthermore, verify that you have the supported Locales listed in the faces-config.


<application>
    <locale-config>
      <default-locale>en</default-locale>
      <supported-locale>en</supported-locale>
      <supported-locale>fr</supported-locale>
      <supported-locale>de</supported-locale>
      <supported-locale>es</supported-locale>
    </locale-config>
</application>




> Setting Locale on ViewRoot to an EL Expression is broken
> --------------------------------------------------------
>
>                 Key: SHALE-437
>                 URL: https://issues.apache.org/struts/browse/SHALE-437
>             Project: Shale
>          Issue Type: Bug
>          Components: Clay
>    Affects Versions: 1.0.4, 1.1.0-SNAPSHOT
>         Environment: JDK 1.[56], Tomcat [56]
>            Reporter: Torsten Krah
>
> The improvement is is resolved there https://issues.apache.org/struts/browse/SHALE-331.
> Cant modify it to reopen it as a "bug" - so i open a new one.
> Like i told on the list, the locale binding is broken for EL expressions.
> Looking at the code i saw the binding expression is set to the ShaleViewRoot.
> But i can change the result of the expression to another locale - the locale of the ViewRoot
still says the same.
> Torsten

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message