servicemix-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Chris Geer <ch...@cxtsoftware.com>
Subject Re: Upgrading Camel...
Date Fri, 13 Apr 2012 18:37:29 GMT
James,

We do exactly what you are asking about. We are using ServiceMix 4.4.1 but
have upgraded Camel and CXF to newer versions to get bug fixes. Our process
is we start with the servicemix minimal distro and tweak it before the
first run. For example, to update camel we run the following commands
against the minimal release.

sed -i .br -e s@2.8.4@2.9.2-SNAPSHOT@gsystem/org/apache/servicemix/apache-servicemix/4.4.1/apache-servicemix-4.4.1-features.xml
rm -Rf system/org/apache/camel
sed -i .br -e s@2.8.4@2.9.2-SNAPSHOT@g etc/org.apache.karaf.features.cfg

We also found it was better to upgrade aries to .3 from .2-incubating so
you need to tweak ActiveMQ

sed -i .br -e s@0.2-incubating@0.3@gsystem/org/apache/activemq/activemq-karaf/5.5.1/activemq-karaf-5.5.1-features.xml

Don't know if it's the correct way to do it but it works.

Chris

On Fri, Apr 13, 2012 at 7:01 AM, James Carman <james@carmanconsulting.com>wrote:

> Is it okay to upgrade the existing version of Camel that's bundled
> with ServiceMix?  We would like to upgrade to Camel 2.9.x.  If so,
> what's the easiest way to do so?  Do we just have both versions
> running inside the container?
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message