servicemix-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jean-Baptiste Onofré (JIRA) <j...@apache.org>
Subject [jira] [Updated] (SM-3763) Changing the version of cxf because of using Brave
Date Fri, 01 Feb 2019 10:07:00 GMT

     [ https://issues.apache.org/jira/browse/SM-3763?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Jean-Baptiste Onofré updated SM-3763:
-------------------------------------
    Component/s: servicemix-assembly

> Changing the version of cxf because of using Brave
> --------------------------------------------------
>
>                 Key: SM-3763
>                 URL: https://issues.apache.org/jira/browse/SM-3763
>             Project: ServiceMix
>          Issue Type: Wish
>          Components: servicemix-assembly
>    Affects Versions: 7.0.1
>            Reporter: bambus
>            Assignee: Jean-Baptiste Onofré
>            Priority: Blocker
>             Fix For: 7.0.2
>
>
> Hello guys,
> I have implemented tracing with Brave in my Java application. I want to package it as
a bundle but after deploying on Service Mix I have a lot of errors. The main problem is that
Service Mix 7.0.1 is using cxf 3.1.9 and Brave is implemented after cxf 3.1.12 version. So
now I want to change my cxf version so I could make that work. 
> Is there any way to change the cxf version?
> I have tried to manually remove everything in: /opt/apache-servicemix-7.0.1/system/org/apache/cxf
that has version 3.1.9 and added a new with 3.2.5 version.
> But when I go feature:list everything from cxf is again with 3.1.9 version.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message