servicemix-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jean-Baptiste Onofré (JIRA) <j...@apache.org>
Subject [jira] [Assigned] (SMX4-1791) Invalid version in Eclipse-BundleSource header
Date Sat, 05 Jul 2014 13:06:34 GMT

     [ https://issues.apache.org/jira/browse/SMX4-1791?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Jean-Baptiste Onofré reassigned SMX4-1791:
------------------------------------------

    Assignee: Jean-Baptiste Onofré

> Invalid version in Eclipse-BundleSource header
> ----------------------------------------------
>
>                 Key: SMX4-1791
>                 URL: https://issues.apache.org/jira/browse/SMX4-1791
>             Project: ServiceMix 4
>          Issue Type: Bug
>          Components: Bundles
>            Reporter: Peter Kullmann
>            Assignee: Jean-Baptiste Onofré
>            Priority: Minor
>             Fix For: bundles-2014.07
>
>
> The Eclipse-SourceBundle manifest entry in the source bundles for fop and xmlgraphics-commons
have an invalid version:
> Bundle-Name                              Apache ServiceMix :: Bundles :: fop     
> Bundle-SymbolicName                      org.apache.servicemix.bundles.fop.source
> Bundle-Vendor                            The Apache Software Foundation          
> Bundle-Version                           1.1.0.2                                 
> Created-By                               Apache Maven Bundle Plugin              
> Eclipse-SourceBundle                     org.apache.servicemix.bundles.fop;version="1.1_2"
> Bundle-Name                              Apache ServiceMix :: Bundles :: xmlgraphics-commons
> Bundle-SymbolicName                      org.apache.servicemix.bundles.xmlgraphics-commons.source
> Bundle-Vendor                            The Apache Software Foundation          
> Bundle-Version                           1.5.0.1                                 
> Created-By                               Apache Maven Bundle Plugin              
> Eclipse-SourceBundle                     org.apache.servicemix.bundles.xmlgraphics-commons;version="1.5_1"
>  
> It should be 1.1.0.2 instead of 1.1_2 for fop and 1.5.0.1 instead of 1.5_1 in the other
case.
> PDE gets confused by these headers:
> Problem processing bundle manifest source header in plug-in Apache ServiceMix :: Bundles
:: fop version 1.1_2



--
This message was sent by Atlassian JIRA
(v6.2#6252)

Mime
View raw message