servicemix-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Gert Vanthienen (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (SMX4-1381) cannot install servicemix-drools feature
Date Mon, 11 Mar 2013 20:53:12 GMT

    [ https://issues.apache.org/jira/browse/SMX4-1381?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13599278#comment-13599278
] 

Gert Vanthienen commented on SMX4-1381:
---------------------------------------

You're probably right - the only solution I see at the moment to deal with those split packages
is to create an uber-bundle again with all of these Drools dependencies inside of it and use
that for servicemix-drools feature.

We used to do that before the Drools JARs had OSGi headers themselves (e.g. we had a similar
bundle for Drools 5.1.1) too.
                
> cannot install servicemix-drools feature
> ----------------------------------------
>
>                 Key: SMX4-1381
>                 URL: https://issues.apache.org/jira/browse/SMX4-1381
>             Project: ServiceMix 4
>          Issue Type: Bug
>          Components: Bundles
>    Affects Versions: 4.5.0
>         Environment: Ubuntu, Oracle JDK 6, Servicemix default assembly
>            Reporter: Mikhail Vasilyev
>             Fix For: 4.5.1
>
>
> karaf@root> features:install servicemix-drools 
> Refreshing bundles org.springframework.core (75), org.apache.xbean.spring (82), org.springframework.context.support
(70)
> ERROR: Bundle org.springframework.osgi.extender [80] Error stopping bundle. (java.lang.NoClassDefFoundError:
org/osgi/framework/ServiceRegistration)
> java.lang.NoClassDefFoundError: org/osgi/framework/ServiceRegistration
> 	at org.springframework.osgi.util.OsgiServiceUtils.unregisterService(OsgiServiceUtils.java:41)
> 	at org.springframework.osgi.extender.internal.support.NamespaceManager.unregisterResolverService(NamespaceManager.java:195)
> 	at org.springframework.osgi.extender.internal.support.NamespaceManager.destroy(NamespaceManager.java:223)
> 	at org.springframework.osgi.extender.internal.activator.ContextLoaderListener.shutdown(ContextLoaderListener.java:547)
> 	at org.springframework.osgi.extender.internal.activator.ContextLoaderListener.stop(ContextLoaderListener.java:431)
> 	at org.apache.felix.framework.util.SecureAction.stopActivator(SecureAction.java:651)
> 	at org.apache.felix.framework.Felix.stopBundle(Felix.java:2278)
> 	at org.apache.felix.framework.Felix$RefreshHelper.stop(Felix.java:4668)
> 	at org.apache.felix.framework.Felix.refreshPackages(Felix.java:3699)
> 	at org.apache.felix.framework.PackageAdminImpl.run(PackageAdminImpl.java:365)
> 	at java.lang.Thread.run(Thread.java:662)
> Caused by: java.lang.ClassNotFoundException: org.osgi.framework.ServiceRegistration not
found by org.springframework.osgi.core [77]
> 	at org.apache.felix.framework.ModuleImpl.findClassOrResourceByDelegation(ModuleImpl.java:812)
> 	at org.apache.felix.framework.ModuleImpl.access$400(ModuleImpl.java:72)
> 	at org.apache.felix.framework.ModuleImpl$ModuleClassLoader.loadClass(ModuleImpl.java:1807)
> 	at java.lang.ClassLoader.loadClass(ClassLoader.java:247)
> 	... 11 more
> *ERROR* Configuration for org.ops4j.pax.web has already been used for service [org.osgi.service.cm.ManagedService,
id=250, bundle=118] and will now also be given to [org.osgi.service.cm.ManagedService, id=321,
bundle=118]
> ERROR: Bundle org.drools.api [202] Error stopping bundle. (java.lang.IllegalStateException:
The service registration is no longer valid.)
> java.lang.IllegalStateException: The service registration is no longer valid.
> 	at org.apache.felix.framework.ServiceRegistrationImpl.getReference(ServiceRegistrationImpl.java:93)
> 	at org.drools.osgi.api.Activator$DroolsServiceTracker.removedService(Activator.java:123)
> 	at org.osgi.util.tracker.ServiceTracker$Tracked.customizerRemoved(ServiceTracker.java:922)
> 	at org.osgi.util.tracker.AbstractTracked.untrack(AbstractTracked.java:351)
> 	at org.osgi.util.tracker.ServiceTracker.close(ServiceTracker.java:403)
> 	at org.drools.osgi.api.Activator.stop(Activator.java:72)
> 	at org.apache.felix.framework.util.SecureAction.stopActivator(SecureAction.java:651)
> 	at org.apache.felix.framework.Felix.stopBundle(Felix.java:2278)
> 	at org.apache.felix.framework.Felix.uninstallBundle(Felix.java:2377)
> 	at org.apache.felix.framework.BundleImpl.uninstall(BundleImpl.java:995)
> 	at org.apache.karaf.features.internal.FeaturesServiceImpl.installFeatures(FeaturesServiceImpl.java:379)
> 	at org.apache.karaf.features.internal.FeaturesServiceImpl.installFeature(FeaturesServiceImpl.java:283)
> 	at org.apache.karaf.features.internal.FeaturesServiceImpl.installFeature(FeaturesServiceImpl.java:279)
> 	at org.apache.karaf.features.command.InstallFeatureCommand.doExecute(InstallFeatureCommand.java:62)
> 	at org.apache.karaf.features.command.FeaturesCommandSupport.doExecute(FeaturesCommandSupport.java:39)
> 	at org.apache.karaf.shell.console.OsgiCommandSupport.execute(OsgiCommandSupport.java:38)
> 	at org.apache.felix.gogo.commands.basic.AbstractCommand.execute(AbstractCommand.java:35)
> 	at org.apache.felix.gogo.runtime.CommandProxy.execute(CommandProxy.java:78)
> 	at org.apache.felix.gogo.runtime.Closure.executeCmd(Closure.java:474)
> 	at org.apache.felix.gogo.runtime.Closure.executeStatement(Closure.java:400)
> 	at org.apache.felix.gogo.runtime.Pipe.run(Pipe.java:108)
> 	at org.apache.felix.gogo.runtime.Closure.execute(Closure.java:183)
> 	at org.apache.felix.gogo.runtime.Closure.execute(Closure.java:120)
> 	at org.apache.felix.gogo.runtime.CommandSessionImpl.execute(CommandSessionImpl.java:89)
> 	at org.apache.karaf.shell.console.jline.Console.run(Console.java:173)
> 	at java.lang.Thread.run(Thread.java:662)
> Error executing command: Could not start bundle mvn:org.apache.servicemix/servicemix-drools/2013.01
in feature(s) servicemix-drools-2013.01: Uses constraint violation. Unable to resolve module
servicemix-drools [211.0] because it is exposed to package 'org.drools.event' from modules
org.drools.core [204.0] and org.drools.api [202.0] via two dependency chains.
> Chain 1:
>   servicemix-drools [211.0]
>     import: (&(package=org.drools.event)(version>=5.5.0))
>      |
>     export: package=org.drools.event
>   org.drools.core [204.0]
> Chain 2:
>   servicemix-drools [211.0]
>     import: (&(package=org.drools.event)(version>=5.5.0))
>      |
>     export: package=org.drools.event
>   org.drools.api [202.0]

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message