servicemix-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jean-Baptiste Onofré ...@nanthrax.net>
Subject Re: [DISCUSS] Apache ServiceMix 3.4 release and JBI Maven plugin 4.5
Date Wed, 04 May 2011 12:38:11 GMT
Nevermind guy.

With the help of Gert, I've broken the cyclic dependency :)

Regards
JB

On 05/04/2011 12:25 PM, Jean-Baptiste Onofré wrote:
> Hi all,
>
> I fixed the last issues around samples and WSN2005 component this morning.
> I'm quite ready to cut off the ServiceMix 3.4 release but I have an issue.
>
> In order to be able to run examples/basic example, I had to update the
> JBI maven plugin with a new ServiceMix version (only the SLF4J
> dependency update).
>
> So, it means that JBI Maven Plugin 4.5-SNAPSHOT uses ServiceMix
> 3.4-SNAPSHOT.
> And, in ServiceMix 3.4-SNAPSHOT, I need to use JBI Maven Plugin
> 4.5-SNAPSHOT (required by the basic example as it uses
> jbi:embeddedServicemix MOJO).
> So I introduced a cyclic dependency, only for this release as the JBI
> Maven Plugin should be the same for next ServiceMix 3 release (if there
> is one :)).
>
> I propose the following:
> - locally release JBI Maven Plugin 4.5 on my machine
> - release ServiceMix 3.4 referencing JBI Maven Plugin 4.5
> - release JBI Maven Plugin 4.5
> The two releases will be on the same staging repository and the vote
> will cover both. Like this, we will be consistent at promotion time.
>
> Is it OK for you ?
>
> Thanks,
> Regards
> JB

Mime
View raw message