servicemix-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Tom Purcell (JIRA)" <j...@apache.org>
Subject [jira] Created: (SM-1216) NoClassDefFoundError: org/aopalliance/intercept/MethodInvocation
Date Tue, 05 Feb 2008 19:06:35 GMT
 NoClassDefFoundError: org/aopalliance/intercept/MethodInvocation
-----------------------------------------------------------------

                 Key: SM-1216
                 URL: https://issues.apache.org/activemq/browse/SM-1216
             Project: ServiceMix
          Issue Type: Bug
          Components: servicemix-eip
    Affects Versions: 3.2.1
         Environment: Linux and Windows
            Reporter: Tom Purcell


I'm running ServiceMix from the linux binary download (apache-servicemix-3.2.1.tar.gz). One
of my SUs use the servicemix-eip component. When I run a test against it I get the following
in ServiceMix log:

java.lang.NoClassDefFoundError: org/aopalliance/intercept/MethodInvocation
        at org.apache.servicemix.bean.support.BeanInfo.introspect(BeanInfo.java:130)
        at org.apache.servicemix.bean.support.BeanInfo.introspect(BeanInfo.java:95)
        at org.apache.servicemix.bean.support.BeanInfo.introspect(BeanInfo.java:69)
        at org.apache.servicemix.bean.BeanEndpoint.getBeanInfo(BeanEndpoint.java:184)
        at org.apache.servicemix.bean.BeanEndpoint.onProviderExchange(BeanEndpoint.java:248)
        at org.apache.servicemix.bean.BeanEndpoint.process(BeanEndpoint.java:211)
        at org.apache.servicemix.common.AsyncBaseLifeCycle.doProcess(AsyncBaseLifeCycle.java:538)
        at org.apache.servicemix.common.AsyncBaseLifeCycle.processExchange(AsyncBaseLifeCycle.java:490)
        at org.apache.servicemix.common.BaseLifeCycle.onMessageExchange(BaseLifeCycle.java:46)
        at org.apache.servicemix.jbi.messaging.DeliveryChannelImpl.processInBound(DeliveryChannelImpl.java:610)
        at org.apache.servicemix.jbi.nmr.flow.AbstractFlow.doRouting(AbstractFlow.java:170)
        at org.apache.servicemix.jbi.nmr.flow.seda.SedaFlow.doRouting(SedaFlow.java:167)
        at org.apache.servicemix.jbi.nmr.flow.seda.SedaQueue$1.run(SedaQueue.java:134)
        at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:650)
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:675)
        at java.lang.Thread.run(Thread.java:595)

What is missing is the aopalliance-1.0.jar. I copied that jar to the apache-servicemix-3.2.1/lib
directory, restarted ServiceMix, ran my test client and everything worked.

I figured I may have screwed something up so I downloaded it again today and sure enough it
looks like that jar is missing from the linux binary distribution. I downloaded the windows
version (apache-servicemix-3.2.1.zip) and it appears to be missing from there too.


-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message