servicemix-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Chris Custine (JIRA)" <>
Subject [jira] Commented: (SM-1216) NoClassDefFoundError: org/aopalliance/intercept/MethodInvocation
Date Wed, 06 Feb 2008 18:10:37 GMT


Chris Custine commented on SM-1216:

Spring AOP was added for Camel, but the aopalliance jar was not added to the assembly.  The
war distro is fine because it packages all transient dependencies automatically.

>  NoClassDefFoundError: org/aopalliance/intercept/MethodInvocation
> -----------------------------------------------------------------
>                 Key: SM-1216
>                 URL:
>             Project: ServiceMix
>          Issue Type: Bug
>          Components: servicemix-eip
>    Affects Versions: 3.2.1
>         Environment: Linux and Windows
>            Reporter: Tom Purcell
>            Assignee: Chris Custine
>             Fix For: 3.2.2, 3.3
> I'm running ServiceMix from the linux binary download (apache-servicemix-3.2.1.tar.gz).
One of my SUs use the servicemix-eip component. When I run a test against it I get the following
in ServiceMix log:
> java.lang.NoClassDefFoundError: org/aopalliance/intercept/MethodInvocation
>         at
>         at
>         at
>         at org.apache.servicemix.bean.BeanEndpoint.getBeanInfo(
>         at org.apache.servicemix.bean.BeanEndpoint.onProviderExchange(
>         at org.apache.servicemix.bean.BeanEndpoint.process(
>         at org.apache.servicemix.common.AsyncBaseLifeCycle.doProcess(
>         at org.apache.servicemix.common.AsyncBaseLifeCycle.processExchange(
>         at org.apache.servicemix.common.BaseLifeCycle.onMessageExchange(
>         at org.apache.servicemix.jbi.messaging.DeliveryChannelImpl.processInBound(
>         at org.apache.servicemix.jbi.nmr.flow.AbstractFlow.doRouting(
>         at org.apache.servicemix.jbi.nmr.flow.seda.SedaFlow.doRouting(
>         at org.apache.servicemix.jbi.nmr.flow.seda.SedaQueue$
>         at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(
>         at java.util.concurrent.ThreadPoolExecutor$
>         at
> What is missing is the aopalliance-1.0.jar. I copied that jar to the apache-servicemix-3.2.1/lib
directory, restarted ServiceMix, ran my test client and everything worked.
> I figured I may have screwed something up so I downloaded it again today and sure enough
it looks like that jar is missing from the linux binary distribution. I downloaded the windows
version ( and it appears to be missing from there too.

This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

View raw message